nikejp63

Installing Orbx Products via FTX Central Causing g2d.dll Crash

Recommended Posts

I'll try to be brief. When I have the latest P3D v4 loaded with no addons, I have no issues. When I install Orbx Global Base or Vector via FTX Central 3, I get a g2d.dll error and P3d crashes. This happens when the scenario is loading the terrain. It doesn't happen all of the time. What happens is I'll choose a default aircraft, choose a random airport and it will either crash while the scenario is loading the terrain or it will load successfully. If the airport I choose crashes, it will always crash. If the airport I choose doesn't crash, it will always not crash. To me it sounds like certain scenery files are getting corrupted. I then have to reinstall P3D.

I have tried manually downloaded the Orbx files and then point FTX Central 3 to install the downloaded files. I have deleted and reinstalled FTX Central. I have completely deleted and installed my nvidia drivers. I have cleaned my registry. I have ran Windows system file check. I have ran chkdsk /f /r on my drives. Antivirus is off while I run FTX Central. Please don't point me to the "CTD guide", I have done that. This problem has been going for a month. I posted on Orbx's forum, the response I got was " a simple search on the internet of g2d.dll will guide you". That doesn't help. Posted on P3D forum, no help there except for the typical standard "try our troubleshooting guide". I need someone who is PC software smart to help me with this. I don't know what else to try. Thanks in advance.

Nick

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

The AVSIM CTD Guide provides some probable fixes for the G2D.dll error:

G2D.dll - This module handles plain text messages, like the frame rate counter and those other plain text messages you see periodically while running any simulator and the plain text words in the respective Menu, like the words Options, View, etc.  There may be something corrupted in your dll.xml which loads menu items. Possible fixes –

  • Rebuild the sim’s config, as appropriate (moving or renaming the config and then restarting the application). 
  • Uninstall/reinstall video card drivers or go back to previous version.  Make sure drivers are not ‘beta’.
  • Move the dll.xml to a temporary folder and see if this fixes the problem.  If so, there is a module in the dll.xml that is causing the problem.

These are solutions found based on searches around the Internet at all flight sim websites.  I realize they are not all inclusive and there are obviously more solutions out there.  The G2D and the G3D errors are common in flight simulation and very difficult to diagnose.

The way I look at the error is the fact not everyone who owns Orbx Global Base/Vector for P3Dv4 has not suffered the consequences of having a G2D error.  Therefore, it must be an issue with your particular installation of P3D.  I personally suspect you do not have all of the permissions to run P3Dv4.  P3Dv4 must have permission of all users as different users on your system have different privileges.

To make sure every user on your computer has access to P3D and P3D add-ons, you need to go to Prepar3D.exe in your main P3D Folder, right click it and select Properties.  Once open, go to the compatibility tab and select the Compatibility tab and make sure the application is run as an Administrator for ALL users.  See page 11, AVSIM CTD Guide for images on exactly how to do this and further information.

Hope this helps.

Best regards,

Jim

 

 

Share this post


Link to post

Appreciate the response, but it doesn't help me. I've been through all this. Everything you suggested has been tried or checked. I am the only user on my PC. I understand nobody else has this issue as I have not seen this particular issue in my countless hours of researching the problem. I troubleshoot software and hardware issues for a living and the bottom line is, plain P3D with no addons runs fine, add Orbx products through FTX Central and the sim crashes with a g2d.dll application error while the scenario is loading terrain. Worked fine for 2 years with P3D v2.5, 3.0 and Orbx products and all of sudden doesn't work. I still say the scenery files are getting corrupted, but I don't know how or why. Is it a Windows 7 issue? I was hoping for a miracle that there was a software guru looking at these posts and could say that he knew what the issue is. Apparently not. My only other option is to buy Windows 10 and install. But that doesn't guarantee that my problem will be solved. Heavy sigh. 

Share this post


Link to post
7 minutes ago, nikejp63 said:

I am the only user on my PC.

You are not the only user.  Besides your user account, there's also a default user, a guest user, a system user, an Administrator, and Authenticated Users.  Each one has certain privileges.  If you click on the Security tab (next to the compatibility tab) you will see them. 

19 minutes ago, nikejp63 said:

I was hoping for a miracle that there was a software guru looking at these posts and could say that he knew what the issue is. Apparently not.

Comments like this on AVSIM is not considered appropriate and I will not tolerate such comments here on AVSIM.  I hope you understand completely.  Members try to help the best they can based on their knowledge.  If the responses did not help you, then you take a deep breath and move on and try something else. 

If you did do a Google search for the G2D error you would see there are no computer experts who can fix this problem for you.  There simply is no one solution. 

Did you run the Migration tool after installing the FTX products?  You can force migration via FTX Central.  Running it several times does no harm.

You should post your question in the AVSIM FTX/Orbx Support Forum.  I'll move this to that forum so those users can maybe assist you. I still wonder why you did not request official support for your products at FTX/Orbx.  I say this because you did not request official support for your product at Orbx/FTX.  If you look at their forums, they indicate whether the issue is active or whether it has been resolved.  Again, there is no solution for the G2D error so they will not be able to fix this for you as the G2D.dll belongs to Lockheed Martin.  People have errors using FTX/Orbx products all of the time and they are not all G2D errors.  There could be a StackHash or NTDLL error too.  Good luck!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now