Sign in to follow this  
pilot100ll

Frustrated with Saitek

Recommended Posts

So I finished loading all my software (FSX and P3D v3 and v4). Super clean system runs flawlessly. Tried to load SPAD.next and what a disaster. It won't load my Saitek controllers (switch, autopilot, radio) when I run the wizard. Test connection failed. SPAD.next does not find the A2A 172 professional trainer either. So frustrated I had had to walk away. All that time to run a clean system and now this. Downloaded simconnect, and nothing. Downloaded fsuipc and nothing. What am I doing wrong? All I want to do is fly my A2A 172 trainer. Nothing else. Any suggestions on getting these silly Saitek panels to function properly? I have instrument panels coming too. If I knew that Saitek was so difficult to get up and running I would have thought twice about their panels. Please help.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this