baldomero

Can't install Prepar3d

Recommended Posts

I'm several days ago struggling trying to install Prepar3d. I have got many error messages, I have done my best to fix them just for get another message.

I have Windows 7 and Prepar3d Academic v3. As for Registry in H_ Local Machine ... Software\wow6432Node\Lockheed Martin\Prepar3d v3 I have:

Prepar3d v3 / Prepar3d v3 Content / Prepar3d v3 Scenery, and  in the three the key SetUpPath = C:\Prepar3d\, since the root where the program is sent is C:\Prepar3d.

Well, on installing Prepar3d DirectX, Client are installed and begins to install Content; after a while I get the message:

"Prepar3d v3 Content requires Prepar3d v3 to be installed". Firstly I got this message and put the path correct  The message disapeared and an other started. Fixed it and again the first messsage appears. here I copy the final part of the last log,  where is mention to Content.

 

[0E50:174C][2017-09-01T15:35:50]i319: Applied execute package: DirectX, result: 0x0, restart: None
[14D0:0A20][2017-09-01T15:35:50]i323: Registering package dependency provider: {A43BF6A5-D5F0-4AAA-BF41-65995063EC44}, version: 6.10.1129.0, package: MSXML6_x86
[14D0:0A20][2017-09-01T15:35:50]i301: Applying execute package: MSXML6_x86, action: Install, path: C:\ProgramData\Package Cache\{A43BF6A5-D5F0-4AAA-BF41-65995063EC44}v6.10.1129.0\msxml6_x86.msi, arguments: ' ALLUSERS="1" MSIFASTINSTALL="7"'
[14D0:0A20][2017-09-01T15:35:52]w355: Unable to register source directory: C:\ProgramData\Package Cache\{A43BF6A5-D5F0-4AAA-BF41-65995063EC44}v6.10.1129.0\, product: {A43BF6A5-D5F0-4AAA-BF41-65995063EC44}, reason: 0x80070645. Continuing...
[0E50:174C][2017-09-01T15:35:52]i319: Applied execute package: MSXML6_x86, result: 0x0, restart: None
[14D0:0A20][2017-09-01T15:35:52]i325: Registering dependency: {ef7923e2-4857-4683-820d-a3994d88d709} on package provider: {A43BF6A5-D5F0-4AAA-BF41-65995063EC44}, package: MSXML6_x86
[14D0:0A20][2017-09-01T15:35:52]i323: Registering package dependency provider: {213CD124-D688-436D-9BD8-FFB56DC830BE}, version: 3.0.10.14945, package: Prepar3D
[14D0:0A20][2017-09-01T15:35:52]i301: Applying execute package: Prepar3D, action: Install, path: C:\ProgramData\Package Cache\{213CD124-D688-436D-9BD8-FFB56DC830BE}v3.0.10.14945\Install_Client.msi, arguments: ' ALLUSERS="1" MSIFASTINSTALL="7" PREPAR3D="C:\Prepar3d"'
[0E50:174C][2017-09-01T15:36:52]i319: Applied execute package: Prepar3D, result: 0x0, restart: None
[14D0:0A20][2017-09-01T15:36:52]i325: Registering dependency: {ef7923e2-4857-4683-820d-a3994d88d709} on package provider: {213CD124-D688-436D-9BD8-FFB56DC830BE}, package: Prepar3D
[14D0:0A20][2017-09-01T15:36:52]i323: Registering package dependency provider: {CE8E65FC-9BE3-438A-8449-BCD5E8ACC6BE}, version: 3.0.10.14945, package: Content
[14D0:0A20][2017-09-01T15:36:52]i301: Applying execute package: Content, action: Install, path: C:\ProgramData\Package Cache\{CE8E65FC-9BE3-438A-8449-BCD5E8ACC6BE}v3.0.10.14945\Install_Content.msi, arguments: ' ALLUSERS="1" MSIFASTINSTALL="7" CONTENT="C:\Prepar3d"'
[14D0:0A20][2017-09-01T15:37:27]e000: Error 0x80070643: Failed to install MSI package.
[14D0:0A20][2017-09-01T15:37:27]e000: Error 0x80070643: Failed to execute MSI package.
[0E50:174C][2017-09-01T15:37:27]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[0E50:174C][2017-09-01T15:37:27]i319: Applied execute package: Content, result: 0x80070643, restart: None
[0E50:174C][2017-09-01T15:37:27]e000: Error 0x80070643: Failed to execute MSI package.
[14D0:0A20][2017-09-01T15:37:27]i318: Skipped rollback of package: Content, action: Uninstall, already: Absent
[0E50:174C][2017-09-01T15:37:27]i319: Applied rollback package: Content, result: 0x0, restart: None
[14D0:0A20][2017-09-01T15:37:27]i329: Removed package dependency provider: {CE8E65FC-9BE3-438A-8449-BCD5E8ACC6BE}, package: Content
[14D0:0A20][2017-09-01T15:37:27]i351: Removing cached package: Content, from path: C:\ProgramData\Package Cache\{CE8E65FC-9BE3-438A-8449-BCD5E8ACC6BE}v3.0.10.14945\
[14D0:0A20][2017-09-01T15:37:27]i326: Removed dependency: {ef7923e2-4857-4683-820d-a3994d88d709} on package provider: {213CD124-D688-436D-9BD8-FFB56DC830BE}, package Prepar3D

 

Some help will be welcome. Thank you.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

" Firstly I got this message and put the path correct "

Altering it only makes matters worse. Instead remove the app entirely with the Control Panel and start again.

Share this post


Link to post

It might also be better to download the one large package,instead of multiple client/content etc etc.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now