Sign in to follow this  
GaryRiley

Sound Problem

Recommended Posts

I have tried everything and nothing seems to work, 90% of my plane sound comes from my monitor, I have the Logitech Z906 ( which are great speakers ) but they seem to only play back ground noise......like truck passing by, other planes starting up. The most of the plane sound comes from the monitor. If I mute the monitor I don't hear things like switches.....apu, landing lights switches etc. If I play like a YouTube video everything sounds great, so which leads me to believe its something in the software. I am using a display port for the monitor.....don't know if that's important.

Its Driving Me Nuts !!!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I am using the cables that where provide, I am not using HDMI i'm using the Display Port and cable. I power up the computer this morning and for some reason everything works as it should. I'm am thinking that PMDG setting was set to Monitor audio and not speakers. Thanks for the response.

Share this post


Link to post

The old "power it up in the morning" trick!

Glad it's working, and that's fine looking speaker system.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this