Sign in to follow this  

Win 10 now forces game mode after Fall update - here's how to disable it

Recommended Posts

MS continues to force certain features on their users and with the Fall Creators update, the controversial Game Mode is now enabled by default with no way to switch it on or off unless you edit the registry. 

As Game Mode only really works with games from the Windows store, and is suspected to cause issues with other games, you may want to disable it on your sim PC. 

Here's how its done:

Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Three points.

One - I turned off game mode when it was first released and I've just checked the registry and it's still off after the Fall Creators update. The update doesn't force it back on. If you hadn't previously turned it off, then you're correct that you've lost the easy option to do so now.

Two - it's not just Windows store games that it works with. See: where they try it with Hitman and Witcher3.

Three - even if you leave game mode on in the registry, Microsoft says it will only be activated automatically for games that have been specifically whitelisted to use it. For most games, you need to activate it on a per-game basis using the Windows key + G to call up the game bar whilst running the game and then select it on in the settings option.

That said, unless your system specification is borderline for being able to run a particular game (where it could well make a difference), there's probably no reason to keep game mode on globally.


  • Upvote 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this