Shourjyo

Stuttering and frame skipping in Prepar3D V4

Recommended Posts

Hello everyone, I am new to P3D V4 and the sim stutters or skips frame every 2-3 secs and this happens after I install a preset using PTA or apply cloud texture through REX 4 or add a new scenery or texture but the stutter disappears if I delete the Preaprd3d.cfg file and let the sim create a new one.

My question is that why every time i have to create a new .cfg file as creating a new graphics settings every time after installing scenery is quite painful ?

Deleting only the shaders cache folders does nothing.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Stutters could be because you replace the P3D textures with high resolution REX4 textures which could then be too heavy for your machine. Have you checked the resolution of the REX textures before adding them?

Share this post


Link to post

@andreh I have selected 1024 for clouds but the stutter goes away if I delete the prepar3d.cfg file and let the sim create a new one.

Share this post


Link to post
1 hour ago, Shourjyo said:

Hello everyone, I am new to P3D V4 and the sim stutters or skips frame every 2-3 secs...

What are your computer specs and model of graphics card?

Share this post


Link to post
7 minutes ago, Henry Street said:

What are your computer specs and model of graphics card?

Intel pentium g4400 3.5ghz

8gb ram 2133mhz

Gtx 1050 oc 2gb

I know these are entry level specs but before using PTA it ran smooth with 35-50 fps depending on location though I run it in 30fps locked with RTSS in 1080p hdtv and I saw that everytime i install any preset or any texture or scenery related thing I need to delete that prepar3d.cfg to get rid of that frame skipping thing which occurs every 2-3 sec.

Share this post


Link to post

I'm inclined to agree with Andre that you are using textures of too high resolution for your graphics card. I don't have Rex but this would be easy to test.

Install the lowest resolution Rex textures, probably 512x512. In the P3D settings, anything with textures, select "low".

See what happens.

 

 

 

Share this post


Link to post
10 minutes ago, Henry Street said:

I'm inclined to agree with Andre that you are using textures of too high resolution for your graphics card. I don't have Rex but this would be easy to test.

Install the lowest resolution Rex textures, probably 512x512. In the P3D settings, anything with textures, select "low".

See what happens.

 

 

 

I tried using the 512 texture for clouds and also changed the in game texture resolution to 512 but still the stutter persists 

 

Share this post


Link to post
49 minutes ago, Shourjyo said:

I tried using the 512 texture for clouds and also changed the in game texture resolution to 512 but still the stutter persists 

One more thing to try...with the textures set to low. set both autogen settings to below normal. If that doesn't help you might want to post over in the PTA forum to see if it might be related to PTA.

Share this post


Link to post

Also be sure to chose DXT1 and DXT5 compression in REX instead of 32-bit. 32-bit hits performance

Andre

 

 

  • Upvote 1

Share this post


Link to post

I have tested everything from choosing dxt5 and dxt1 to setting the graphics settings to as mininium as possible but still the frame skipping is there. I have restored original shaders using PTA but the problem is still there. Could it be a problem of v-sync or prepar3d.cfg ?

Share this post


Link to post

I don't use vsync (don't have a problem with screen tearing). There is an Avsim P3D configuration guide below. Although v4 pushes more graphics processing to the graphics card, all the basic info in the guide will still apply.  

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now