Rob Ainscough

Pause/Stutter solution/compromise for XP11 and WT3

Recommended Posts

I was suffering from performance issues in XP11 with World Traffic 3 and was trying to figure why ... as it turned out, the source of the issue was adding XP11's AI traffic and selecting WT3/Other as the source and enabling the remote plug-in feature so that the WT3 AI traffic would show up in my RealityXP GTN750 and/or Little Nav Map.  

So made a quick video of a solution that is sorta a compromise (no AI traffic showing up in GTN 750):

Because WT3 AI traffic is "injected" (object instances generate "on the fly") and it seems third party products like Little Nav Map and RealityXP GTN750 don't see the WT3 traffic "as is", there was/is a need to add XP11 AI traffic using WT3 as the source and then enable the remote plug-in under WT3 preferences.

My semi-solution that seems to allow WT3 AI traffic to still show in Little Nav Map, but not in the GTN750, does recover performance back to "normal" levels.

As we all know, stutters/pauses can have many sources, hopefully this "solution" might help those that encountered it with WT3 and remote plug-ins.

Personally I think this is a bug in XP11, I can't see why adding just 7 or 8 XP11 AI traffic should trigger a 30-40% drop in FPS.  Hopefully this potential bug can be addressed in future releases.  But for now, this is the best compromise I could come up with.

Cheers, Rob.

 

  • Like 1
  • Upvote 2

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Thanks Rob, I've pinned this into the tips & tricks section.

Share this post


Link to post
Share on other sites