cbe0004

Elevator Trim Issues

Recommended Posts

My PC12 has recently started to act up and I'm not sure what the cause is. The elevator trim was fine then after I installed Bert's panel mod and several repaints the bird needs about -10 degree trim to fly level from about 150 knots and up. I restored the panel to the original state and the issue is still there. Also looked through the aircraft.cfg to see if I accidentally deleted something but found nothing out of the ordinary. It is flying like the flaps are down but they are not.  Do any of you have any ideas I can try? 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

On 4/10/2018 at 7:40 AM, cbe0004 said:

My PC12 has recently started to act up and I'm not sure what the cause is. The elevator trim was fine then after I installed Bert's panel mod and several repaints the bird needs about -10 degree trim to fly level from about 150 knots and up. I restored the panel to the original state and the issue is still there. Also looked through the aircraft.cfg to see if I accidentally deleted something but found nothing out of the ordinary. It is flying like the flaps are down but they are not.  Do any of you have any ideas I can try? 

Bert adds the engine mod and that does change too many things so the FDE is not realistic. Email Bert to see if he has something that could help

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now