l0stsignal

Garmin trainer software DirectX not working?

Recommended Posts

When running the garmin trainer software, I get the error, "A directx component has suffered an irretrievable component error"

I'm running an nvidia gtx 1080 on windows 10. I've scoured the internet for a solution and have installed the windows directx packs without anything working. I've tried older drivers and the latest without any success

My understanding is if the garmin trainer does not work, the realityxp program to add it to my panel will not work. Is this correct?

Has anyone solved this problem?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

Have you actually tried the Reality XP GTN in X-Plane? It might prove to work despite the error you are getting with the trainer alone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now