Deaf Pilot

Lens Flare effects not working 100%...

Recommended Posts

Good evening gents.

I'm still using P3Dv3.4

I haven't been able to make the lens flare effect work uniformly across all views. The lens flare effect works beautifully from the Spot view, but in the VC (where I really want it to work even more so than Spot view), it is just a plain, no frill sun with no glare whatsoever. I have checked some of the camera defs and cfgs but I think I am missing something somewhere, because no view gives me a good, bright sun glare except for the Spot view. Can someone shed some light on where I can find the cfg settings for this? Would seriously enhance the effect of having the bright, setting/rising sun glare in your face if you're flying into the sun. 

Thanks in advance!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

  You can find the setting for lens flare effect in vc in the cameras.cfg file.

C:\Users\here_your_name\AppData\Roaming\Lockheed Martin\Prepar3D v4\

change this

[CameraDefinition.002]

Title = Virtual Cockpit

...

ShowLensFlare=TRUE

Thats it. Have fun.

Edited by Rasterfahnder

Share this post


Link to post

I use Envshade (performance setting) + Envtex's sun flare set 3 and sun texture depending on the time of year. Try it and you get "sun glare in y our face if you're flying into the sun". Looks real. But you have to enable lensflare in the p3d grafics options. Before envtex I never used lensflare because it is an optical effect you just get when you look thru a optical lens like a video camera. Set 3 gives just a nice glare effect. I think you  wont be disappointed.

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now