Jump to content

Sign in to follow this  
DaniloAlonso

ChasePlane not open (SimConnect issue?)

Recommended Posts

Hi!

 

ChasePlane works very well until yesterday, when I installed my new adddon A2A Comanche 250.

The A2A plane wont worked (CTD when switch to Comanche 250) and the solution was reinstalling the P3Dv4.4 (clean install, deleted everything) and all addons. (Windows 10 Pro x64)

  • Installed P3Dv4.4... OK!
  • Installed SimConnect (redist\Interface\FSX-SP2-XPACK\retail\lib\SimConnect.msi)... OK!
  • Installed A2A Comanche 250... OK! (the CTD is gone and the plane worked!)
  • Installed VFXCentral and ChasePlane... "error"!

The "error" is that the ChasePlane dont know the installation of the SimConnect, and shows the MessageBox below, (click OK, then he "install" the simconnect, that already installed, and exit):

Missing SimConnect assembly
---------------------------
ChasePlane need to install the SimConnect assembly. Click OK to launch the SimConnect installer. Simply relaunch ChasePlane after the installation is completed.

I have tried to re-install SimConnect and not worked. Appears to be a missing file, don't know.

This is a ESSENTIAL addon and can't fly with the bizarre default cameras of P3D =(

Share this post


Link to post
Share on other sites

Solved!

The SimConnect was installed, but NOT....

Well... I have uninstalled the SimConnect trying to solve some problems with my Comanche... and deleted the folders in C:\Windows\WinSXS (have taken ownership of these folders to ME and deleted)...
The problem is: when I have installed again the SimConnect, the folders with DLLs don't have created in Windows\WinSXS!

Then I reverted back the 'ownership' of these folders to the "ThrustedInstaller" (using a "power prompt"), then, reinstalled the SimConnect again and.. DONE!!!
Chaseplane OK.... Comanche OK.... FSEconomy OK (the FS Economy wont worked too)!!

This saved me of "install the Windows 10 again" 😃

Share this post


Link to post
Share on other sites

Good find.. but i am trying to understand that folder  C:\Windows\WinSXS at least on my computer is over ten gigs   you just deleted the whole thing?

Thanks

steve

Share this post


Link to post
Share on other sites

No, you should not delete the items in this folder. There are essential items to run the system, if you delete something, this will ruin Windows installation.

For some reason the SimConnect don't removed the folders when I have uninstalled... bugs LOL

Share this post


Link to post
Share on other sites

Dear @DaniloAlonso,

how did you manage to revert the ownership of the simconnect folders?

I'm having the exact same issue as you, but I am not able to fix this. Just tried to restore my windows, but that didn't work as the process got stuck multiple times.

Cheers

Benjamin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    14%
    $3,575.00 of $25,000.00 Donate Now
×
×
  • Create New...