Sign in to follow this  
Aidan Hegarty

Cannot download liveries via Operations Centre

Recommended Posts

Finally got round to buying the 777 plus the -300 expansion.

Am running it on P3D v 3.4

I cannot seem to download the liveries via the Ops Centre. It displays the available liveries but clicking on the download button does nothing - well almost nothing. It displays 'downloading' for a fraction of a second then stops.

Also I have noted that any updates in the notification sections don't seem to install. I click on OK to install updates and they appear to install, then the next time I open the Ops centre i get new prompts to install the same updates

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

53 minutes ago, Aidan Hegarty said:

Finally got round to buying the 777 plus the -300 expansion.

Am running it on P3D v 3.4

I cannot seem to download the liveries via the Ops Centre. It displays the available liveries but clicking on the download button does nothing - well almost nothing. It displays 'downloading' for a fraction of a second then stops.

Also I have noted that any updates in the notification sections don't seem to install. I click on OK to install updates and they appear to install, then the next time I open the Ops centre i get new prompts to install the same updates

Can you please open a support ticket from the support.precisionmanuals.com portal?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this