DDWareing

Black Screen. GTN won't power up.

Recommended Posts

Ok I'm at my wits end here on this. I can't get the GTN to show anything. All I get is a black screen. I am trying this in the Carenado 210 and the Milviz 310. Neither of them work. The odd thing is the RealityXP GTN works great for me in P3D using the 6.5 trainer. I've read the other threads but nothing really helped and none of the solutions worked for me. Again the wierd thing is that in P3D the RXP GTN works just fine. What am I missing. Thanks.

Things I know for sure. Garmin is installed in default location. No quarantined files in my AV. And again works great in P3D  on all aircraft I have it installed with. And yes I own both the XP11 and P3D versions of the RXP GTN.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,

can you please post the content of the RXP log files?

Share this post


Link to post
Share on other sites

Ok this is what I got. Hope I am looking at the right logs. 

19/01/20 00:09:49.898 19592 -    ] # rxpGtnSim64.dll version 2.5.11.0
19/01/20 00:09:49.897 19592 INFO ] 
19/01/20 00:10:20.709 17264 INFO ] 
19/01/20 00:12:03.614 09156 INFO ] 
19/01/20 00:12:32.023 17928 INFO ] GTN: 01 ..\..\src\krnl\krnl_lib\sim\hwm_nand_drvr_sim.c(827) (null)

Share this post


Link to post
Share on other sites

Thank you. Are you by any chance running X-Plane as admin? 

Share this post


Link to post
Share on other sites
2 hours ago, RXP said:

Thank you. Are you by any chance running X-Plane as admin? 

No.

Share this post


Link to post
Share on other sites

Hi,

We're investigating this and we might have found a reason why this could cause this, introduced in our latest v2.5.11 unfortunately. The fix is on its way along with a few more post v2.5.11 corrections/enhancements.

Share this post


Link to post
Share on other sites

To Whom It May Concern,

Just would like to inform that I am experiencing the same problem as DDWareing

Just purchase GTN750 & GTN650.

Besides the Black Screen I have another issue as follows:

When I open the Garmin Aviation Trainers, there is a message on the bottom written in red: "Cannot load trainer packages because an installation directory is missing"

Does not tell me what directory.

Tried to uninstall the Aviation Trainers to reinstall, but did not find where I can do that.

Also where can I find the RXP Log Files?

As I read you are coming up with corrections\enhancements to correct the Black Screen issue.

How do I find out when the revised version is available.

Please advise.

Thanks

Share this post


Link to post
Share on other sites

@5outrage5 Hi,

Uninstalling the Garmin trainer: like any other Windows program. For example on Win7: Control Panel.

Have you tried to install the Garmin trainer in a non C: drive? or installed as admin? Just retry installation in C: as normal user.

As for RXP log files, see the RXP GTN User's Manual for file/path.

We always announce new versions/updates in our forums (see pinned discussion for this). Within the GTN Configuration Panel GUI (FltSim) or the GTN Menu (XPlane) there is a 'check updates...' option. 

In addition, the next update adds an option to subscribe to update notifications so that your computer will check from time to time automatically.

Share this post


Link to post
Share on other sites

Hi,

i had the same problem. I reinstalled the program, deactivating all other plugins... but no chance. It didn't worked.

But then, i started X-Plane 11 as a Admin and it finally worked again. I don't know why, but it worked.

 

If you have the same problem, then give it a try.

 

Regards

 

Tom

Share this post


Link to post
Share on other sites

Hi,

further update about the update: we're still working on it but we are nearly done. We've incidentally found another bug which could randomly make anything (crash, lock up etc...) at startup, both in our GTN and GNS V2. It could randomly happen about 1/50. 

  • Like 1

Share this post


Link to post
Share on other sites

I also am experiencing black screen.  Will not power on in the trainer nor in any aircraft.  Just started after reinstall two days ago.  I have tried everything recommended, no go.   Using XP11.30.

Edited by Yzhammer

Share this post


Link to post
Share on other sites

I too am experiencing the issue with black / blank screen since the update. Have reinstalled 3 times including Garmin software and clearing out the links in the registry and still just black / blank screen. I appreciate and look forward to the next RXP update that adresses this issue and I suppose it's back to the GNS 530 for now.

Thank you RXP in your effort to repair and update to fix the issue. Just wanted to say that another user is having this issue is all.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now