Bentree_

No display on Go-Flight Radio modules anymore

Recommended Posts

Hi,

After i start using Linda to program my Go-Flight modules, the RADIO display and NAV display of the Go-Flight Modules don't light up anymore. (i do not use the MCP Combo! Nor any other radio devices, only the Go-Flight ones)

The modules work, because when i turn the knob, in the sim the dails change, its only that the frequency displays on the Go-Flight Modules don't work.

The Radio and Nav module is not connected to linda, it is still run from the Go-Flight interface.

Is there something i can do? I would like the displays to show the frequencies.

Thanks in advance for any help, regards,

Ben

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Ben

LINDA is not specifically designed for Go Flight hardware and none has been fully tested with LINDA. All hardware (other than VRI Combo panels) is treated as simple HID or Joystick devices. No control is provided for panel lighting. 

What you may be experiencing is the changes to Win10 USB power management which requires you to make some manual changes as described here.

If your Go Flight hardware was previously working correctly I suggest you revert to that software and disable the Go Flight devices in LINDA’s Joystick Setup page.

Share this post


Link to post
Share on other sites

Hi Andrew,

Thanks for jumping in this tread.

For all my USB devices i unticked the"switch off by windows 10 mode to save power". Some had the power management tab, others didn't.

Further identifying USB devices like it is explained in the tread you refer to is too difficult for me.

Now, the problem is that the GF radios's are not shown in Linda, that was my first action and idea....just disable management of the radio's in Linda....but i can't find them the so i can not untick them in Linda too.

1. Any further idea's?

2. When i can not have it fixed, i tend to buy Saitek radio's, but then again i am affraid the have the same problem....what can you say about that?

Regards,

Ben

Share this post


Link to post
Share on other sites

It is probable that your GF Radio does not appear as a HID Device (or joystick) and requires specialist drivers and software to work correctly. If this is the case LINDA will not recognise it  

LINDA will handle the Saitek Radio Panel providing standard COM/NAV controls. You just tick the Saitek Panels checkbox in LINDA Setup. 

Edited by ScotFlieger

Share this post


Link to post
Share on other sites

Thanks Andrew,

I just did a couple of testflights in several aircraft and restarted the PC and P3D over and over, don't ask met how....but the numbers in de Go-Flight radio's are working at the moment....so the problems are over i suppose

regards,

Ben

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now