Sign in to follow this  

[Questions] Some issues with WMR

Recommended Posts

I have had my Samsung Odyssey+ for 2 months. I have figured most of the issues. I have now very statisfied with running it at 60hz with renderTargetScale=2 and motionReprojectionMode=auto. Very smooth. Taxi at airports is amazing.


I have got for last issues.


1) No cabins sounds from the headset, like flaps movements. If I want cabin sounds I need to turn sound off from the Odyssey and use regular earbuds from the 3.5 jack.

2) P3d minimised as soon as the face sensor is blocked. I must you the mouse to unminimize.

3) Lost of mouse/Win+Y doesn't work. I must always go out of VR, restart steamVR,re -nable VR for the mouse to work again.


I got used to the last 2, But I would really like to fix #1. I cannot use Pilot2ATC in VR.


Share this post

Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I start Steam VR before I start P3D V4.4. In the P3D sound setting select the head set as the primary sound device. Also make sure the headset is the selected windows playback device. Once you do all of that you might need to restart P3D. I think the main thing is to start SteamVR before you start P3D. Also deselect "pause on task switch" in P3D general setting. Make sure P3D is in focus when you are in VR. i.e. click on the P3D window before you put the headset on.

If you are using A2A aircraft you have to set the headset to the primary sound device un the alt addons menu for the A2A aircraft cockpit sounds to work in VR. That will require a restart of P3D too. It's import to start SreamVR first. I think that solves most of the sound related problems with P3D in VR

I am just learning the ins and out s of VR myself so I cannot promise any of the above will work for you but it work with sound issues for me.

Share this post

Link to post
Share on other sites

I've got my recipe:

1) Indeed, start WindowMixedRealtyPortal. Starting that creates the new usb audio device. If you start P3d before, it confuses Majestic Q400 and PMGD planes.

2) Disable in device adio via the WMR configuration. 

3) Use earbuds with microphone that I keep on both 2D and VR during a flight.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this