betampona

little navmap on a client PC connected to an X-plane server

Recommended Posts

Hello, I was using before with the same Little Navmap installation last version with FSX-SE, I had no problem.
Now I have switched to X-Plane11last version and I have a connection problem on the remote PC.
I installed the Little Xpconnect plugin in plugin X-Plane11 on the PC X-Plane11
I installed little Navconnect and ran it on the X-Plane11 PC
As this still didn't work on the remote PC, I installed Little Navmap on the X-Plane PC11 and it works on the X-Plane PC11 but still not on the remote PC.
On the remote PC I downloaded the X-Plane11 data
I followed your recommendations for installation.
As far as communication between the 2 computers with FSX-SE is concerned, it works.
Greetings.

Dominique

Translated with www.DeepL.com/Translator

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Dominique,

5 hours ago, betampona said:

I installed the Little Xpconnect plugin in plugin X-Plane11 on the PC X-Plane11

Look if you can see Xpconnect in the X-Plane plugin manager to check if it is installed correctly.

5 hours ago, betampona said:

I installed little Navconnect and ran it on the X-Plane11 PC

Do you see the message "connected to simulator" (or alike) in Navconnect?

Did you switch to X-Plane in Navconnect since it may still try to connect to FSX (in case both sims are on the same computer)?

Also, do not forget to change the IP address or computer name in the LNM connect dialog on the remote if FSX and XP11 are on different computers.

5 hours ago, betampona said:

On the remote PC I downloaded the X-Plane11 data

You don't have to copy the X-Plane data but only the LNM databases. Do not forget to select the X-Plane scenery library on the remote computer.

Alex

Share this post


Link to post
Share on other sites

Hello, I'm still having trouble connecting to X-plane11 on my client PC.
For FSX-SE this works perfectly.
Do we have to do anything in X-plane to have the dialogue.
Currently I have 2 utilities for X-plane11 that work, ZHSI for standalone instruments on the client PC where Little Navmap is and also XplaneCDU in wifi on a tablet.
If I connect to the X-plane PC, Little Navmap works perfectly.
If I look at the PC X-plane, Little Navconnect it is well connected to X-plane11
Awaiting a response.
Greetings. 

Dominique

Translated with www.DeepL.com/Translator

Share this post


Link to post
Share on other sites

Hi Dominique,

2 hours ago, betampona said:

Do we have to do anything in X-plane to have the dialogue.

Yes. Install the Little Xpconnect plugin that comes with the LNM download. This is a X-Plane plugin that is needed for Navconnect and Navmap to connect to X-Plane.

I suppose you already checked the manual here: Comment exécuter une configuration réseau

Alex

Share this post


Link to post
Share on other sites

Hello, I launch X-plane11 then Little Navconnect which tells me that it is well connected to X-plane11. The Little XPconnect plugin is well in X-plane11 plugin.
On the network PC I launch Little Navmap and in Tools/connection to the flight simulator I enter the name of the PC X-plane11 or its IP nothing happens connection.
I checked my firewall, looked at the ports.
The same installation works for FSX-SE.
Greetings.

Dominique

Translated with www.DeepL.com/Translator

Share this post


Link to post
Share on other sites

Hi Dominique,

looks like your are running all correctly. Can you send me the log files of Navconnect on the flying computer and Navmap on the remote?

Let Navconnect connect to X-Plane and try Navmap to connect to Navconnect. Then quit all and send me the log files. Contact address is on my page. Log files are linked in the respective about dialogs.

Best,

Alex

 

Share this post


Link to post
Share on other sites

Hi Dominique,

thank you for the log files and sorry for late replay. Too much work in real life.

I see no obvious errors. So, you are using the right IP address, correct port, Navconnect is listening normally and connected to Xpconnect.

What I see is that Navmap cannot connect to Navconnect

.. default WARN ]: Error reading from "192.168.1.27" : 51968 "Connexion expirée" open true state QAbstractSocket::UnconnectedState

I have no idea why and suppose this can be only a firewall problem.

Best regards,

Alex

Share this post


Link to post
Share on other sites

Hello, I removed the firewalls on both computers and I was able to connect to X-plane11, I put the firewalls back on the PCs and I still have the connection to x-plane. For me it's resolved.
Insisted in your documentation that for Little Navmap it is not an automatic connection as for fSX, but that you must launch the Little Navconnect utility.
Greetings.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now