Figadas

Syntax Error GNSSv2 + Piston Duke v2

Recommended Posts

Hello everybody,

I've been trying for a couple of weeks now to get the 430+530 v2 combo working on the Piston Duke v2 (FSX + Win10).

Bert helped me a while ago adapting his Prepar3d GPS500 panel modification to run on my setup and I'm very thankful for his help, but it would be nice specially to have the 430 and the 530 running together "natively"

Everything works well on the Turbine Duke after renaming the new v2 RXP.dll so RealAir config panel recognizes the modules, but if I do the same thing on the Piston Duke, when I go to select to use the RXP I get this Error: chunk has too many syntax levels.

Is there a solution to have the stack working on FSX?

thank you and thanks again Bert for your help!

regards,

Igor

syntax_zpsgmdcetrp.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Igor,

I sent you my panel.cfg for my older RXP gauges.  I would be interested to know if it works for you as I am considering upgrading to V2.  I also use FSX.

David

 

  • Like 2

Share this post


Link to post
Share on other sites

Hi David, 

Thank you for the file.

I'll report back once I have a chance to give it a try later tonight.

 

regards,

Igor

Share this post


Link to post
Share on other sites

Hi there David, unfortunately the panel.cfg didn't work.

The Panel itself didn't change, so I only had the native FSX GPS and the RXP was behind it, so I guess I need first to find a way to let the Duke know that I want the RXP 530+430 panel layout to be active and then try to add both GPS editing config files.

Or even easier, have a solution for the syntax error so I can just run the RealAir's Panel Config and have the RXP working.

Thank you for the file though, t might be just a  matter of editing a file or two..

Have to say right now, I regret moving to V2, everything worked perfectly with the old GNSS

Share this post


Link to post
Share on other sites

Did you change the options.xml file to the correct value (30)?  That file controls what GPS arrangement to display in the virtual cockpit. Sounds like it was still set to the default GPS.  XML files are very fussy, and the file had to be changed exactly as I showed you in my second email.  You will also need to change all the gauge name references from rxpGNS to rxpGNS2, I believe.

David

 

  • Like 2

Share this post


Link to post
Share on other sites

HI there David,

I did change the xml, but I didnt change the rxpGNS to v2 because I originally renamed the actual V2 file to match the V1 old filename, it was a workaround to have the newer GNSS working.

What I'm going to do today is I'm going update the GNSS since RXP released a new versio, I'm also going to put the new RXPGNS2.dll (If I'm not mistaken) back to the folder as the active RXP file and then rename all the references on your cfg, options etc to match the new v2.

I'll let you know.

thank you

regards,

Igor

Share this post


Link to post
Share on other sites

It works!!!

Oh my... finally, thank you so much David, also Bert that assisted me a while ago since I first tried to get this going.

So the reason why I never got to get this working editing panel.cfg and the other files myself was the XML file. When David, you mentioned that xml files are very fussy I went back to it, highlighted and made sure that all spacing were right and every time I tested and failed I would re-open the xml just to see that the value was back to 0 from 30. SO I highlighted every space on that live and presses spacebar, and even though all spacing was originally correct, for whatever reason the file finally recognized the new value (30) and everything worked properly.

Thank you so much again for all your help, thank you again Bert too for sending me all your P3D files and helping me modify them for FSX.

You can go ahead David and get the GNSS V2, I can now finally report they both work on both Piston and Turbin Duke v2

Thank you

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now