Jump to content

Alberto Zanot

[FIX] Terrain shadow degradation fix for v4

Recommended Posts

Hello, i've noticed that from the virtual cockpit the ground shadows suffer of a big degradation (see picture)

S0KQltK.jpg

I found a way to fix it.
Here it is:

  • Go in C:\Users\YOUR_NAME\AppData\Roaming\Lockheed Martin\Prepar3D v4
  • Make a backup copy of your prepar3d.cfg and cameras.cfg
  • Open cameras.cfg and find the Virtual Cockpit one. It is the [CameraDefinition.xxx] with the entry "Origin=Virtual Cockpit". If you don't use any camera addon, it should be the first or second one. If you use ChasePlane it is the one with the entry "Description=ChasePlane Virtual Cockpit Camera". Any other camera addon could have different description. Anyways usually it is the first one. Just find yours.
  • In that camera, change the entry: Clipmode=Minimum (add it if you don't have it) and add FarClipOverride=200000 (you find what Far and Near Clip Planes are here)
  • Save, close, and open prepar3d.cfg, look for the entries inside the [GRAPHICS] tag
  • Change these entries like this:
    SHADOW_QUALITY=3
    SHADOW_DRAW_DISTANCE=3
    SHADOW_NUM_CASCADES_LOW=12
    SHADOW_NUM_CASCADES_MID=12
    SHADOW_NUM_CASCADES_HIGH=12
    SHADOW_NUM_CASCADES_ULTRA=12
    OPAQUE_SHADOW_TEXTURE_SIZE=2048
    TRANSLUCENT_SHADOW_TEXTURE_SIZE=512
    OPAQUE_SHADOW_DRAW_DISTANCE=2000
    TRANSLUCENT_SHADOW_DRAW_DISTANCE=2000
    SHADOW_LOG_PARTITION_LOW=0.990000
    SHADOW_LOG_PARTITION_MID=0.990000
    SHADOW_LOG_PARTITION_HIGH=0.990000
    SHADOW_LOG_PARTITION_ULTRA=0.990000
  • Save. Now the quality of the shadow and the fps impact is not depending by "SHADOW_QUALITY" (don't touch it and don't change nothing in the in-game sim menu), but you can set the quality with "OPAQUE_SHADOW_TEXTURE_SIZE". Valid entries are: 512, 1024, 2048, 4096, 8192. In my system 2048 looks nice and have no fps impact. Chose the value that fits best your system. The higher the value, the more defined the shadows (with fps impact).
    SHADOW_DRAW_DISTANCE=3 is the maximum draw distance and if you use the clouds to cast shadows on terrain/sea, 3 is the best setting, otherwise you will see clouds shadows clean cut (ugly).

A note about the FarClipOverride: the value 200000 means that the simulator renders the terrain 200 km far in the horizon. If you fly like 40.000ft high, this is a good setting. But if you go higher and higher you could see the terrain clean cut at the horizon. In this case, try raising the value.

Hope this helps, and if it doesn't work / you don't like it, just restore your cfg backups.

Have a nice flight!

 

  • Like 2
  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...