Jump to content

Sign in to follow this  
C2615

Horrible Control lock (seems by AP TOGA) experience

Recommended Posts

Ok guys, this is my fresh "post crash" flight story in P3D(v4.5HF3), while there are some technique issue I would love if someone could explain, that's not the main point for me to post this topic.

Like all story, it starts as a routine flight, I plan a small hop from RJFF to RJKA with feelthere E170, after my previous 2 uneventful legs from RJCH-RJBE-RJFF in FSL319 and P3D restarted.

My DP from RJFF is MORIO3, 2 rectangle right turn after taking off from RW34 to heading south.  All preflight and take-off are normal, after takeoff, I manually fly though flaps retracted above 4000' (NADP1) and the first turn, then AP engaged in NAV and VNAV mode.

The 2nd turn done by AP, while slightly over shoot, it's correcting, after the aircraft turning back to route it stating to capture back by a slight left turn, then, it seems the left turn can't be stoped, and the airplane is starting to deviate from route to the left.

"OK, fine, some buggy NAV path from feelthere, fair enough, I have seen something like this even from PMDG", so I just switched to HDG mode and turn it back on course.

Then seems the HDG didn't work, so natually, I disconnect the autopilot and roll my joystick to right.

That when I realised the "*thigh* has hit the fan". it doesn't work. the autopilot was connected as FMA annoced, but my airplane refused to respond my right roll input.

TIM20200524182645.png

Now my airplane has leved off itself at bearing 056, still climbing with full throttle, and no responds to any of my stick and rudder input. Even the yoke in VC dosen't move with my joystick.

"Emmmm, I have seen this." I have recalled my distant memory in FS9 with GA727 and a freeware KingairB300, "it must be the 'default AP' jamd on at TO/GA mode"

Since the AP disconnect button on my joystick is mapped by Feelthere's loadmanager, I reach to the "Z" key, and "Shift+R" for autothrottle, after that, still nothing. TCS button? no help.

Now I start worrying, I reach to FSUIPC and set my button to "AUTOPILOT_OFF",and "AP_master" , still, no control.

I tried reengage and disengage E170's AP by mouse push few times, doen't work out. BTW I have checked my joystick input, they are all good.

Now the airplane is rockting over FL250, on the puls side, it's flying level and stright with a little climb, at least not at risk for a while.

While not think it's that well simulated, I reach the checklist, turn off the FCM button and pull disconnect handle, MFD shows my control surface is in direct mode or disonnected, but I can feel the AP is still actively controlling the airplane.

The throttle is also jamed in full, I can bring them back by moving my throttle device, but as soon as there is no new input, it will shoot back to full. But for stick and rudder, not even a glitch.

Now what, I just want my aircraft back, I disconned all electric, still, the AP is active with blank PFD/MFD!

Still thinking it's the AP TOGA problem, I reach to the LINDA dev mode and try to send both AP_off control and directly change offset of 0x07VC and 0x080C, without any luck. also tried to send offeset command by FSUIPC button mapping, nothing.

I tried to close some program like AIFlow/AIgroudn , Lorby flashlight and FSX2ACIM etc, see if it's them interfering some offset. but nothing.

Now the aircraft steady at FL310 somehow, it has power to accelerate, the CRZ alt I set was 280, and the setting in AP panel is all over the place by now, the FL310 seems been choosen by itself.

To avoide overspeed, I have to bring back throttle constantly, while trying anyway I could think to disconnect the AP.

While all three trim is under my command, The AP can easily override all my trim input. even with the stabilizer full up or full down.

Prepar3-D-2020-05-24-16-51-58-36.jpg

Prepar3-D-2020-05-24-16-53-51-93.jpg

Now I admit there would be no way I can disconnect the AP. I tried to figure out how could I land this thing before I ran out of fuel, which I didn't bring too much.

Trim and differentia throttle would easily been canceled by flight control input, I can't even hold the throttle back to lower my alt, even if I tried hard and steadily stall my airplane, as soon as I give up, the AP will bring it back to FL310

I can lower the landing gear, that will give my in a steady near stall at FL310,  but hardly loss any altitude. Speed brake won't work as engine is not in idle, and flaps won't go out anyway.

While sort of cheating, I went to Failure menu and failed the control surface, that turns out to be a disaster, it also disabled all my trim input, so I have to turn them back. Fail the Hyd sys and Elec sys doesn't have any effect at all.

    BTW, when AP try to save the airplane from free fall, the control indication on MFD shows normal deflaction of control surface, without any aerodynamic effecet as they failed...seems feelthere only got it to show where the yoke is...

Then I start to manipulation the AP panel, while I had ATT FAIL, miraculously, I can control AP pitch and throttle somehow.

Roll, HDG and NAV still don't work, but I can now command a steady VS though E170's AP,  and hold an inputted AT speed, while doing so, the yoke in VC and elevator indicator gose full up, but viewing from outside, the tailplane looks normal. seeme the default AP is still trying to command TOGA, but E170's AP can beat it somehow.

If I disconnect E170's AP, the airplane will pitch up violently, then adjust to steady climb.

Prepar3-D-2020-05-24-17-24-12-99.jpg

Prepar3-D-2020-05-24-17-26-04-78.jpg

Now I had some of my control back, actually, almost all the pitch control, I need to find somewhere to land.

That's hard, After few more try, I can't figure out how to control my heading anyway.... I kind of regret I have full elec thus IRSs off, but concidering the heading isn't controlled at the very begining, that might not ge better.

While ditch near the shore of Japan is a good choice in reallife or in XP, it's not an option in P3D then....

With low fuel and sun setting, I just went any flat(ish) land I can see. Flaps still not working with low sped and alt somehow, but I can slow to 150kts, I planned to grab the fire handle as soon as touch down, as the STRAT/STOP switch won't work in air in case of bancing ,

Prepar3-D-2020-05-24-17-39-08-12.jpg

And sure, that's just a crash, only if I turned the "detect crash" on...... welcome to the Ryotsu island....

Prepar3-D-2020-05-24-17-41-09-52.jpg

Yet, after Evec, the AP still hoding my yoke and throttle HARD

Prepar3-D-2020-05-24-17-41-27-74.jpg

==================

To find out why, I switched to default Braon58, it seems working fine without AP engeged what soever.

Then I switch back to E170, in cold and dark mode, the Yoke now not firmly jamed, but jumping (flashing) back and froth from center to my Joystick position. that looks weried, but after I powered up,  that glitch gone.

Then I test fly with AP (but no time for MCDU route), and even deliberately inject the default TO/GA command via FSUIPC and LINDA, I can't reproduce the same phenomenon.

For safety, I set the "autothrottle_takeoff_ga ="  to 0 in aircraft.cfg, Feelthere's Ejet TOGA logic works fine without the default one.

 

This is my personal experience with a "black swan" type emergency, No procedure could cover it, I tried to deal it with all my knowledge both inside and outside of aviation (actually, feels it's more about software stuff...). the outcome? not so good IMO....

I still think it's about Autopilot jamed at on, and with feelthere's Ejet, when AP is normally on, the joystick has no input effect, just as what happend in this scenario. But I just don't have the skill and time to go though all the debug procedure. And seems I might not be able to repreduce it (and actually, I hope not).

Share this post


Link to post
Posted (edited)

Now things are going wild, After 2 peaceful flight yesterday, Today I have almost identical occurrence on Carenado PC12!

It happend while cruising, but AP and RXP750 have the airplane well in control I didn't even noticed it.

only when I start to decent, I notice the throttle couldn't be bring down, end then I look my VC Yoke, it's full aft and right.

After I disconnect PC12's AP, the airplane goes to same trajectory as E170 above, but different heading, about 330 this time, and level off at FL170 (I cruized at FL160 as planed)

After a few try, I can only regain control by reloading(select and OK the same aircraft) PC12. luckly PC12 is much simper aircraft than E170.

This really terrified me, as if it could happen in ANY aircraft.

A few guys posted simular issue with ASP3D+PMDG aircraft and WXR on, but in my case, I had ASP3Db3 installed, then it doesn't work well with my 4.5HF3 so I leave it and uninstalled it's P4 interface (the one under mydocument\Prepar3D v4 Add-ons) but leave the main program of ASP3D untouched. then use back the ASforP3Dv4

I tried to close ASforV4 when it strike, but it doesn't help me to regain control.

However it's the only major change of my sim before these 2 occurence I could recall, it's definitely worth to look into, I'll remove both AS and reinstall AS for P3Dv4 to see if it would happen again, but as I don't even know what would trigger it, it's hard to tell...

Edited by C2615

Share this post


Link to post

After reinstall AS it strkes again last sunday (with FSL319), I reinstalled FSUIPC6 and legendry  simconnect. test fly for 20h+ with no issue, then set to my normal flight 2~3 h pre day. without issue 3 day stright....

Then it happens again....Without anything I could see as a "trigger" at all it just happend at mid (actually, 3 minutes before TOD) of flight...

Nothing I could found related in FSUIPC's Full log and ContentErrors.txt, that's a big bump for me, I test for this week hope it not happen, or if it happens, pick it on log...but nah....

The behaivor is as above, aircraft seems be "hack" to an autopilot, which command a giving heding(different every time and not the heading when it happend), and climb or descent to FL170 on PC12 and FL310 for Jets, thrust locked to max while able to be bring down briefly, but other 3 axis are fully been taken, and it will adjust for wind and turbulence to acive it's target, as the yoke moving in VC for that adjust, but not even jerk for my input.  For E170 and PC12, autopilot could overpower it, the Yoke in VC wil "fight aginst" the AP input, try to bring aircraft to that HDG and FL310/170, and result showing full deflection in VC, but control surface outside seems working with AP, the FSL's AP just doesn't work.

Reloading scenery\ SLEW or move to an airport  doesn't resolve, but reload aircraft will kill this effect and regain my control.

I just hope someone could identfy what module could be behind the problem......

 

I still could think of some add-ons might be related to this... but the most frustration thing is I might need weeks to get one happen, without knowing any trigger for it. that will get my debug test process very painful...

Share this post


Link to post

OK, after I tried to update all my add_ons, it still not working....

So, I roll back to HF2, and after 2 weeks of flying, seems it's all good now......

Due to it's behavior, I don't think it's cause by one or two corrupt file in my HF3 installer, I have redownloaded it, but just not urgent to install and test it again....

By edit regedit to fake the version number, the FSL320 .450 works fine for now....but I don't know if one day I'll have to go to HF3 again with newer FSL or ASP3D update....

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    28%
    $7,080.00 of $25,000.00 Donate Now
×
×
  • Create New...