Jump to content

Sign in to follow this  
R Smith

[Resolved] Issue with AI lights on the FSPX Belouga.

Recommended Posts

Hi, i bought the FSPX Belouga AI model for p3dv4, however i'm getting a strange issue with the lights, when the aircraft starts up the taxi lights will come on but the Nav lights, Beacon lights do not.

Once the aircraft enters the runway the landing lights come on but the Nav, Beacon and strobes are not on.

Once it takes off they are still off  but once the aircraft get far enough away from my position the missing lights will suddenly come on as they should, if i then zoom in they go off again until i zoom out again.

I've ran the lights configuration as normal and the model hasn't appeared on the incompatible list, I'm not sure where to look.

 

Hope you can help, thanks.

Edited by R Smith

Richard Smith

Share this post


Link to post
Share on other sites

Hi Richard,

Has Mitssi stated this model is now compatible with AI lights reborn?  He has been converting his models one by one and stating when these are AILRP fully compatible.

Can you check the documentation of this AI model? It is normally stated there if it is compatible.

I don't own this particular model to check.

S.

 

Share this post


Link to post
Share on other sites

Hi Simbol, yes according to the PDF manual it is compatible with Ai Reborn.

 


Richard Smith

Share this post


Link to post
Share on other sites
18 minutes ago, R Smith said:

Hi Simbol, yes according to the PDF manual it is compatible with Ai Reborn.

 

Then something is off. Be sure to click apply settings, restart P3D and use the live preview to confirm the effects.

Remember I don't control the lights during normal simulation.. Only during live preview, so it is possible Mitssi put some tags on the lights causing these behaviors.

This is why I always ask people to use the live preview module to check the effects configuration. Please try that first, if you use expert interface, you can select which AI model you want to see during preview, so select the beluga and see how it looks like using my preview module.

S.

Share this post


Link to post
Share on other sites

Hi, ok tried applying setting again but still no joy, used the preview mode and i can see it's applying the lights, just seems to only display them all at long distance, it's like the LOD distance is affecting it.

Please see pics linked, the first two you can see taxi and landing lights but no other lights, and in the last three of the aircraft approaching the runway you can see as i zoom in the nav lights ect dissapear.

https://drive.google.com/drive/folders/1xTqZZXp16p1TKSHbHPEUNApQwsvSV14W

 

 

 

 

 

 

 


Richard Smith

Share this post


Link to post
Share on other sites

Hello, I've just done a quick experiment, I restored the original Aircraft.cfg file and it looks exactly the same as before, it appears AI lights reborn isn't making any changes to it at all.

 

(Edit) Ok looking inside the Aircraft.cfg it isn't applying the settings, the models show in the configurator though.

Edited by R Smith

Richard Smith

Share this post


Link to post
Share on other sites

Ok i'm sure this isn't caused by your program, in the default Aircraft.cfg there are no entries for lights at all, see below.

 

// --------------------------------------------------------------------------------------------------------------------


[LIGHTS]
//Types: 1=beacon, 2=strobe, 3=navigation, 4=cockpit, 5=landing, 6=Taxi, 7=Recognition, 8=Wing, 9=Logo, 10=Cabin

 

[EFFECTS]
wake=fx_wake
water=fx_spray
dirt=fx_tchdrt
touchdown=fx_tchdwn, 1
vaportrail_l= fx_dummy
vaportrail_r= fx_dummy

 

That's all there is, surely that's not right as all the other AI's have much more in this section.


Richard Smith

Share this post


Link to post
Share on other sites

FSPX uses lights attached to the models, that is why you see nothing in the config file.

Can you do a preview with another FSPX model and compare the results?  Then a non FSPX model and also compare.

This is to check effects are firing and your system is configured correctly.

Confirm you are running version 1.24, and AILRP configuration is set to use FSREBORN scaling techniques or lights will scale using default P3D algorithms which are not as accurate as mines.

S.

Share this post


Link to post
Share on other sites

Hi, I'm using FSreborn optimized for 4k scaling setting, i don't have another FSPX model to compare, I've added some shots of UTL traffic to my google drive account, i've also looked in the CFG files and theres fsreborn entries in them.


Richard Smith

Share this post


Link to post
Share on other sites
25 minutes ago, R Smith said:

Hi, I'm using FSreborn optimized for 4k scaling setting, i don't have another FSPX model to compare, I've added some shots of UTL traffic to my google drive account, i've also looked in the CFG files and theres fsreborn entries in them.

Richard,

Then give me a couple of days, I will ask mitssy to give me a couple of this model because I don;t own it.. after that I can check things from my side.

S.

Share this post


Link to post
Share on other sites
16 hours ago, R Smith said:

Ok thanks.

 

Hi Richard,

Spoke to Mitssy this morning, the Beluga .MDL (model file) for P3D V4 is incorrect / corrupt and it is the reason why you are having this problem. Mitssy will need to fix the .MDL file and upload it to Simmarket, etc. If you open the AILRP reports and checked models with missing Beacons,missing navs and missing strobes.. you will find the Beluga listed.. so next time verify all the tabs, no just the incompatible tabs.

In the meantime try to you use the P3D V5 MDL version, see if it loads under V4. This version has the correct effects names and it will work with AILRP. So if you open the Beluga install files, go to P3D V5, find the Model folder and replace your installed model folder for this one.

I would advise:

1) Leave P3D closed

2) open AILRP,

3) re-scan,

4) click apply.

5) Launch P3D V4, select the beluga under AILRP and click preview.. check if the effects are there.

Alternatively you can wait until Mitssy repairs his V4 .MDL file.

Regards,

Simbol

Share this post


Link to post
Share on other sites

Hi, yes i've seen his post on the facebook group, i got to say you guys provide excellent support.

 

  • Upvote 1

Richard Smith

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    39%
    $9,950.00 of $25,000.00 Donate Now
×
×
  • Create New...