Sign in to follow this  
Guest N247K

Elevator Sensitivity - FSX

Recommended Posts

I have a superb Logitech Force 3D Pro joystick ... I guess the old "Microsoft" joystick is no longer manufactured.I am adjusting every parameter I can find, in the aircraft.cfg files and in the "settings" tab in FSX.But, after a nice flight, while on short final, any slight hint of a pitch adjustment, and the nose is to the stars or the earth.Any adjustment out there to tame this beast?Many thanks in advance for help!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If your framerate is a tad low (<15fps) then reactions to joystick input can be pretty big. I had the problem in the beginning too.I recommend use all tweaks to get the framerate up so that the sim is running smooth.Also set the sensitivity of the joystick in the controls options a tad down (to the left) and perhaps calibrating the stick in the options if you haven't done so already might help a bit too.But nevertheless, in reality and in the sim you control your plane basically with tiny movements.A very important thing though is that you trim your plane for the attitude and speed needed (Numpad 1 or 7 for up and down when numlock is off). If you don't trim the elevator you need to use "force" to keep the attitude, that is push or pull the stick, and that will sooner or later always result in a pretty rough flightpath.Also if you have big reactions then you might just have a too high speed on approach?What i really dislike about force feedback though is when using the autopilot you still can get force feedback which can make the stick go nuts if you dare to take your hand off.

Share this post


Link to post
Share on other sites

I'll try a larger NULL ZONE and let you know.I just got a new Intel Core2Duo-3.6gHz machine that has FSX, which I just installed Wednesday, running really smoothly.I have the "target Frame rate" set at 25, and it is really nice.

Share this post


Link to post
Share on other sites

>I am adjusting every parameter I can find, in the aircraft.cfg>files and in the "settings" tab in FSX.Did you try reducing the elevator effectiveness setting in the aircraft.cfg file? That will certainly work.Best regards, Chris

Share this post


Link to post
Share on other sites

Try extremes. You will not break anything. This will quickly tell you if you are in the ballpark. Max and min sensitivity. Big Null or no Null Zone, etc. Does the Logitech device have any utility that allows you to place sensitivity on a curve. This causes low sensitivity at the beginning of movement increasing along with further movement. CHProducts old analog stuff has such a utility.Regards,Dick Boley

Share this post


Link to post
Share on other sites

Match the movement of the controller to the movement of the virtual yoke or stick in the VC. Many times, OVER sensitivity turns out to be UNDER-sensitivity, leading to over-compensation.Allcott

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this