Jump to content

Sign in to follow this  
picnic

Missing Aircraft with X-Plane and Little Nav Map

Recommended Posts

Several x-plane users in our flight sim group have been reporting they don't see all the multi-player aircraft on Little Nav Map. As a result I did some experimenting the other evening.

As far as I could tell all the multiplayer aircraft could be seen in X-Plane but one was always missing in Little Nav Map. It's always the last connection that was missing. So if player 2 left and rejoined you wouldn't see them upon reconnection but you'd now see the previous player you couldn't see before.

Sadly I have no way of knowing if this is a joinFS issue or a Little Nav Map one. What can be done to try and resolve this please?

Posted over at the joinFS forum as well.

Share this post


Link to post
Share on other sites

LNM reads the usual multiplayer datarefs "sim/multiplayer/position/plane..." which are limited to 19 AI aircraft. You can look at these with the dataref editor to check what's going on there. The first aircraft is always excluded in the list of 20 since this is the user aircraft. I don't know if this can cause the issue or if it is a problem with joinFS.

I plan to support the new X-Plane TCAS interface in a future version of LNM which allows more aircraft. No idea if joinFS uses this.

Alex

Share this post


Link to post
Share on other sites

So it appears joinFS is already using the new TCAS interface.

That is interesting. I am no longer using the "sim/multiplayer/position" datarefs, but the "sim/cockpit2/tcas/targets/" instead, which I think Alex might be referring to in that last sentence. So I suppose the question is, why are you seeing any aircraft at all. Unless X-Plane is filling in those multiplayer datarefs from the TCAS information?

I'm more confused than ever now.

Share this post


Link to post
Share on other sites

Hi Alex,

I'm part of the same group as Peter and have been looking into the missing aircraft in LNM. I've spend a little while troubleshooting over the past few days and the pointers are that the issue may rest in LNM...

First step was using JoinFS. I looked at all the datarefs, and X-Plane is doing what's necessary to copy the data injected into the new TCAS interface to the datarefs that you're using. Sure enough there's an online plane missing from the LNM map display. However, the "AI / Multiplayer" tab on the "Simulator Aircraft" window of LNM shows the correct number of other aircraft in the "1 of n" text, but there is one fewer AI aircraft icon displayed on the map. When I click on each of those aircraft icons in turn, the numbers below the "1 of n" text next to the "Number:" label range from 3 to n+1 depending on the aircraft I click on.

Next, I took JoinFS out of the equation and used Traffic Global to inject traffic into the simulator. Had to turn the traffic density down to get a countable number of aircraft, but the same behaviour was seen with this as with JoinFS. Correct number of other aircraft in the "1 of n" text; one fewer displayed on the map; numbers from 3 to n+1 when clicking on the aircraft. Probably important to note that Traffic Global injects traffic using the new TCAS interface too.

Finally, I disabled all add-ins and just used X-Plane native AI aircraft - enabling 5 of them. This time, I could see five displayed on the map. The "1 of n" text however showed "1 of 6". Clicking on the aircraft didn't help as they all had registrations rather than object numbers as identifiers.

I've managed to compile LNM from scratch and am seeing if I can work it out - no joy yet. I'm struggling to build a version of Little XpConnect that works as ideally I'd start my search there. I guess I'm sort of hoping that you might know just where to look to see if this is a problem in the LNM code though!

Hope this helps - or looking forward to the LNM version that uses the TCAS traffic datarefs. Either way, your program is great and an invaluable addition to my Flight Simulator experience.

Share this post


Link to post
Share on other sites

@jarangmandi  Thank you for the feedback. I tried X-Plane with AI up to the maximum of 19 (position 0 is always the user aircraft) again and see no missing aircraft on the map. The count given might be wrong because it still adds the two possible X-Plane ships (despite AI ships disabled). These two are the carrier and the frigate.

The TCAS interface has to be filled by JoinFS. X-Plane does not do this as far as I understood. I'll try traffic global too when implementing the new interface.

I'll have a look at the Xpconnect code again but I'd not waste much time with the old interface. I'd rather concentrate on the TCAS implementation.

Alex

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    45%
    $11,435.00 of $25,000.00 Donate Now
×
×
  • Create New...