Sign in to follow this  
Palebushman

rudders and brakes

Recommended Posts

Greetings to all from Alberta Canada!!My FSX has developed a couple of problems that I have spent mind boggling weeks trying to fix.First of all I have no control over the rudder of any aircraft I try to use..I am using CH pedals.. they seem to be working fine except that they overcompensate every move I make and I cannot even centre the rudder.The other big problem is brakes! A message often appears in the bottom left corner of the screen saying "differential brakes" I am totally unable to control the aircraft using any kind of braking system. I sit in the terminal or on the active runway and I can open the throttles to the firewall and the aircraft wiil not move.I have tried everything I can think of to reset the programme including taking FSX out and reloading it..all to no avail.Would some kind fellow pilot help me out here PLEASE!!! Thanks for your time guys...Phil.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It sounds like there is a conflict between your CH pedals and another input device (joystick, gamepad, etc.). Try disconnecting all your gaming devices, then connect only the pedals, start up FSX with only the pedals connected and see if you can get theem working right. IF you get them working, then connect the joystick or yoke and see if they still work. I noticed that the order in which things are connected does make a difference.For the record, I have CH pedals and a CH yoke (both USB) and they work fine in my FSX. The only time I had a problem like yours was when I had an additional joystick connected too (by mistake).

Share this post


Link to post
Share on other sites

Yup, just as "Flightluur" said, I too had the same trouble.If you have the CH Yoke and Pedals, make sure you remove any other controllers from your machine, especially Microsoft Force Feedback II.You may want to download and install the "Control_Manager_v4.2(32bit)" from the CH website here:- http://www.chproducts.com/retail/downloads.htmlAfter you have done all of the above, it would be prudent to set up and calibrate all the CH conrols actually from within FSX so that sensitivities and null zones behave as required.Just one other tip; if your are like most of the others simmers I read here on AVSIM, you will want your Under-carriage to go UP when you push the respective controller switch UPWARD and the U/Carriage to go DOWN when you press the same switch DOWNWARD, which is NOT the default behavior. To make the U/Carriage switch behave as described above, you will need to add this line into the 'Conrols' folder which is normally found here:- C:Documents and SettingsYour nameApplication DataMicrosoftFSXOpen the 'Conrols' folder, right click on the XML file in there to open it with 'Notepad' and then scroll right down to near the bottom of the page where you will find these lines:- CH FLIGHT SIM YOKE USB {32BEA2B0-B88F-11DB-8002-444553540000}Now sroll down slowly to this line:- 4GEAR_TOGGLECopy the similar additional lines that I have created below here, and Paste them imediately below that entry:- 5GEAR_TOGGLEYour adjustment should now look like this:- 4GEAR_TOGGLE5GEAR_TOGGLEAs you can see, the only difference between the two entries now, is the addition of the number'5' which mysteriously was not there beforehand. Go to the top of Notepad, click on 'File' and then click 'Save' to keep this adjustment to the XML file.Hope the above resolves your dilema and gets you back to happy flying.

Share this post


Link to post
Share on other sites

Thanks very much to both of you...I am going to follow your advice and I will let you know what happens. I got my pilots licence years ago when I was in the RAF and I don't recollect it was as hard as sorting FSX out. Thanks again, Phil.

Share this post


Link to post
Share on other sites

Many of us have labored over the calibration of the rudder axis on our CD Pedals. As mentioned above, careful adjustment of the sensitivity and null zone are required. I have both settings (sensitivity and null) set much lower for the rudder axis than they are for the yoke X and Y axes. Otherwise the rudder just seems to be "twitchy," especially foe nose wheel steering. You'll know when the sensitivity is too low when you can't rurn sharply enough to make a 90* turn and stay on the taxiway :).Toe brakes are yet another matter. I suspect that you need to put a check mark in the differential brake axes "Reverse Axis" checkbox on your pedal's axis assignments page. If these axes are not reversed then the brakes are fully released only when you press them too the floor. You can easily test my theory. When the red "Differetial Brake" message is displayed on your screen, press both brake pedals all the way down. If the message disappears, then the axis reversal checkboxes are wrong (unchecked).R-

Share this post


Link to post
Share on other sites

Hi all,I solved my problems with CH Yoke and Pedals by removing all axis assignments in FSX setup. I then assigned the axis and calibrated them in FSUIPC (I gues that requires a registred version). No problems after that. There is a good instruction on Peter Dowsons' forum.Ulf B

Share this post


Link to post
Share on other sites

Thanks Ron and Ulf...I am going to print out all of this good info..if this doesn't work I cannot imagine what will. I am at the moment running "cleanup" programmes to make sure everything is good on the computer before I start using your suggestions. (I guess I have given away my nationality there by using the English word programmes.. instead of programs, old habits die hard.) Go well, Phil.

Share this post


Link to post
Share on other sites

As has been said, the toe brakes is caused by the reversing of the axes in FS, required to make the brakes work as brakes, not as accelerator pedals!BUT, in so doing you also have reversed the sense in which the sensitivity and null sliders now work - maximum is now minimum and vice versa. So check the tick boxes are enabled in the reverse axes box in the assignment menu, then go to the slider adjustment and set sensitivity to minimum and null to maximum for the brakes. Then adjust from there.It's all quite obvious when you think about it, and you don't need the payware version of FSUIPC to achieve working rudder and pedals, but FSUIPC has a lot of options for control setup that you can't get anywhere else, including changing the response curve from linear to non-linear, and separate sensitivities for each aircraft in the stable. Very, very useful and well worth the money for FSUIPC for that alone, IMHO.Allcott

Share this post


Link to post
Share on other sites

I have got everything working pretty well now, thanks to you guys..I have a paid copy of FSUIPC so I will take a look at that and see if I can further fine tune the controls.There is one more question I would like to ask if I may..then I will stop picking your brains.When I am flying I often like to take a look at the aircraft from the outside views using the hat. But I have to drop down the views menu from FSX to do this..I have the CH throttle quadrant installed, is there any way I can programme a button to let me shift from cockpit view to outside view without going through the FSX menu?Go well, Phil.

Share this post


Link to post
Share on other sites

Hi Phil,With the CH Yoke that we have, going outside the plane or viewing the plane from the Control Tower etc; is all done by pressing either one of the two red buttons on top of the left hand side of the Yoke, using the hat switch on the top right side of the Yoke will 'Pan' the views, and this is all usually the default behaviour too. Not at my simulator machine at the moment but if no one else gets back to you on this one, I can copy all the 'Controls' cfg file of mine so that you can copy and paste the relevant switch tasks to yours and then see if it works OK for you.BE SURE TO COPY YOUR ORIGINAL 'Controls' folder FIRST to another part of your rig for safe keeping, BEFORE YOU MAKE ANY ALTERATIONS to it.

Share this post


Link to post
Share on other sites

Hi Dave......I am ok with the hat panning the views...but tell me how you have set up one of your red buttons to switch from a cockpit view to an outside aircraft view. Perhaps I am missing that when I look down the menu for selecting views. Sorry to bug you, Go well, Phil.

Share this post


Link to post
Share on other sites

Okay Phil here goes,Fire up FSX, go to 'Settings' and then select 'Controls' and click on the middle tab 'Buttons/Keys'Scroll right down to near the bottom of the list where you will meet the line:-View (next category) Keyboard = S. Now click on the 'New Assignment' button and press one of your top L/H red buttons on your Yoke and the number 10 will appear in the empty box. Click OK and the 'Button 10' should now appear in the 'Joystick' column.Now gently scroll down to the 'View (previous category) Keyboard = Shift+S.Click on the 'New Assignment' button again and this time press the other top red button on your Yoke which should appear as 09, click OK. Choose your favourite short flight, climb to about 3000ft and enjoy the wonderful FSX views.

Share this post


Link to post
Share on other sites

Works like a charm mate..very much appreciated indeed.I really needed this option because I am using VFR Photographic Scenery of the UK which is a terrific add on for FSX. I used to live in Wales and this scenery is an actual photograph of the area..it is so accurate that I can easily see the old house we lived in then. Everything is shown just as in an aerial photo which of course it is.You have probably got a copy of it yourself but if not it is well worth the money.I will try not to bug you again, happy flying, go well, Phil.

Share this post


Link to post
Share on other sites

:-beerchug Glad to be of help Phil, which of course is the essence of this wonderful AVSIM form. There are some awesome guys in here and no doubt you will discover them the same way as I have over time.Used to do a fair bit of travelling around Cymru before I retired in 2003. My Queen and me are in transit at the moment here in South Africa and she is whisking me off to live with her in Australia in a couple of weeks time. Which means that I will be 'Off-Line' for a while until we get our machines set up again.Till then have a great time with the new FSX and this great website.:-spacecraft

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this