Jump to content
Sign in to follow this  
packman2002

knobster with MSFS not working

Recommended Posts

dear Daniel, all

as new AxisAndOhs Demo Version (2.27 b09) is out, have tried yesterday to connect my Knobster (siminnovations) to MSFS

the Bridge is connecting fine to AAO main program, green light in the bridge. 
i can assign a button in AAO, select the required button, i turn the knobster, hardware is recognized.  so far so good. see attached picture. (this was not the case with previous version, so one step further=. 

however there is no action in the MSFS aircraft at all !  also i see no green LED light in the main AAO program - assigned button main page when i turn the knobster.  This cannot be correct ?!
looks like AAO is not connecting to MSFS (installed properly with lorbysi-content-hooks in the community folder.

have tried default C172 cessna to assign OBS and Kodiak 100 aircraft with various FMS commands, eg FMS knob or page zoom.no joy. no reaction at all.
(what i need is the FMS knob in fact on the G1000 nxi WT, inner wheel, outer wheel and press button action for VR)

any idea ? am i doing something wrong or is there still a bug in the software.
many thanks Franz

https://ibb.co/ZghW2LG

https://ibb.co/cDLL7f8

 

Share this post


Link to post
Share on other sites

1. You cannot assign up/down events here, only down. Each controller movement is a single button event, and if you assign both, both will be triggered on every click when you turn the controller. For a Knobster you will need a total of 5 button assignments in AAO (inner left/right, outer left/right and the "click" when you press it)

2. I think that the CLICK event is wrong. Very strange, that sould read LEFT TURN or RIGHT TURN. Keep turning the controller when assigning it, until AAO registers the turn. Maybe turn it left/right/left a couple of clicks so the app can pick up the value changes.


LORBY-SI

Share this post


Link to post
Share on other sites

hi

very good. thank you. 
now is working !   here are my mappings.  it does not take every turn of the knob but this does not disturb so much.
just had a crash to desktop, hope will not occur often.

 

https://ibb.co/tqm35pq

Share this post


Link to post
Share on other sites

The last one should be a CLICK, since it is an actual button event. How did it end up as a TURN? Check the Bridge Settings, your device may require the forced "up" event.

I don't have a Knobster, so I can't really offer an opinion about the operation. The Bridge was written "in the blind" as a freeware project for a fellow simmer, but I haven't heard from him in a long time. Still, there were no other complaints about the turning action.


LORBY-SI

Share this post


Link to post
Share on other sites

hi

for the last item::  when i click one time on the knobster i get this one below (click).  but in the SIM it does not work !
https://ibb.co/XYqmLg3

only working is this one, it modifies itself when i click 2 or more  times. and this one works fine in the SIM.
https://ibb.co/dt2YWHW

it does not recognize the first turn of the wheel sometimes but thats minor. thank you for the integration of the knobster.  without having the knobster is not so easy to integrate it.

best regards Franz

Share this post


Link to post
Share on other sites
13 minutes ago, packman2002 said:

for the last item::  when i click one time on the knobster i get this one below (click).  but in the SIM it does not work !

Go to the Settings on the Knobster Bridge program (the button with the gears). Set "Force key up event" to "yes". Then try again with the "CLICK", maybe it will work now.

Apparently not all Knobsters are made equal in their operation. Some send a key up event, some don't. 


LORBY-SI

Share this post


Link to post
Share on other sites
Posted (edited)
21 minutes ago, packman2002 said:

it does not recognize the first turn of the wheel sometimes

Yes, because when it receives the very first event, AAO doesn't know what is happening yet. It needs a second click to determine if this is a simple click or a turn.

I know, this could be implemented in a better way, but at the moment that is how it works. The risk to make changes in this area is very high, since there are a lot of MIDI and bridge devices already in use with AAO. The risk of destroying existing logic has to be weighed carefully against the possible gain when changing it.

Edited by Lorby_SI

LORBY-SI

Share this post


Link to post
Share on other sites
On 3/12/2022 at 7:56 PM, Lorby_SI said:

Go to the Settings on the Knobster Bridge program (the button with the gears). Set "Force key up event" to "yes". Then try again with the "CLICK", maybe it will work now.

Apparently not all Knobsters are made equal in their operation. Some send a key up event, some don't. 

hi,

with Force key up event the main program does not react at all when i press the knobster !

 

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, packman2002 said:

hi,

with Force key up event the main program does not react at all when i press the knobster !

 

Weird. I really wish that I had a Knobster myself to test this. But I don't, and other testers had no complaints (apparently).

You did delete the previous button assignment in AAO and created a new one with "Force key up" active, right? It won't work any other way.

Edited by Lorby_SI

LORBY-SI

Share this post


Link to post
Share on other sites
19 hours ago, Lorby_SI said:

Weird. I really wish that I had a Knobster myself to test this. But I don't, and other testers had no complaints (apparently).

You did delete the previous button assignment in AAO and created a new one with "Force key up" active, right? It won't work any other way.

oops no sorry i modified the existing entry. will re-do and delete / add

. thank you

Share this post


Link to post
Share on other sites

sorry for late testing.  was sick last week (no Covid ! )

when i delete and re-configure the last button assignment, behavior is exactly the same.  does not work when i push one time.
pushing 2 times changes the device from CLICK to TURN_RIGHT

in MSFS push knobster action does only work with TURN_RIGHT:

best regards Franz

 

Share this post


Link to post
Share on other sites
Posted (edited)

I just ran a quick test in software only. When I create a fake event for "1" (which is the ID of the push button) in the Bridge, and send that multiple times (every 5 seconds), it always remains a CLICK. Not changing to TURN ever.

From my perspective everything works as designed. Sorry, that it doesn't work for you, but I am at a loss what else I'm supposed to tell you. I have read that there are different versions of Knobsters out there. The Bridge will only work with the latest hardware, the one that supports their API dll.

Edited by Lorby_SI

LORBY-SI

Share this post


Link to post
Share on other sites

no worries, all works fine here.  also the press function works with the TURN event.  !

it just display the wrong event when pressing multiple times.  but it works.  no issue. 
my knobster is purchased april 2021. about a year old.
thansk for good support.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...