Jump to content
Sign in to follow this  

Axis and Ohs startup time?

Recommended Posts

Hi, I'm trying to get the eval version of AAO working, and then, obviously, evaluate it prior to purchase. It runs, it connects to MSFS 2020, _but_, it takes up to five minutes to discover and acquire USB devices before the UI is displayed. About 3-1/2 if I remove devices I'd like to use, about 5 if I attach them.

I'm running Windows 11, I have vcredist 14.36.32532 installed (both x86 and x64), and .NET 4.8.03928

I'm running AAO as Administrator. 

I've removed most of the USB devices I have, to try to rule out device/driver conflicts, and I've blacklisted everything that AAO allows me to blacklist.

I've tried wiping out the three config folders as you had indicated in another support thread.

Firewall is wide open on localhost to 8080, 8081, 9081. No other processes are listening on those ports prior to launching AAO.

Do you believe that this is normal or expectable behavior, or an anomaly? 

My startup log, with minimal device connections, is:

8/26/2023 10:57:11 AM.136 : Sound folder set: C:\Users\MeMyselfAndI\OneDrive\Documents\LorbyAxisAndOhs Files\Sounds
8/26/2023 10:57:11 AM.137 : Scripts folder set: C:\Users\MeMyselfAndI\OneDrive\Documents\LorbyAxisAndOhs Files\Scripts
8/26/2023 10:57:11 AM.137 : Web server folder set: C:\Users\MeMyselfAndI\OneDrive\Documents\LorbyAxisAndOhs Files\WebPages
8/26/2023 10:57:11 AM.137 : Screenshot folder set: C:\Users\MeMyselfAndI\OneDrive\Pictures\Microsoft Flight Simulator 2020 Files
8/26/2023 10:57:11 AM.138 : Simulator files folder set: C:\Users\MeMyselfAndI\OneDrive\Documents\Microsoft Flight Simulator 2020 Files
8/26/2023 10:57:11 AM.501 : App configuration loaded
8/26/2023 10:57:11 AM.548 : Config database loaded
8/26/2023 10:57:11 AM.712 : Simulator activated
8/26/2023 10:57:31 AM.998 : Found Device ITE Device 07208da0-0edc-11eb-8002-444553540000
8/26/2023 10:57:32 AM.69 : Found Device ITE Device 072a0380-0edc-11eb-8004-444553540000
8/26/2023 10:57:32 AM.73 : Found Device ITE Device(8595) af598200-7eb2-11ec-8004-444553540000
8/26/2023 10:57:32 AM.111 : Found Device ITE Device(8595) af5ed930-7eb2-11ec-8005-444553540000
8/26/2023 10:57:32 AM.120 : Found Device HID-compliant vendor-defined device af595af0-7eb2-11ec-8002-444553540000
8/26/2023 11:00:44 AM.569 : Acquiring devices now
8/26/2023 11:00:44 AM.569 : Device acquisition completed
8/26/2023 11:00:44 AM.728 : Running As Administrator, Web FIPs enabled


Share this post

Link to post
Share on other sites
Posted (edited)

This is not normal.

Looks like you have an incompatible USB device there, the last one that is being queried at 10:57:32 AM.120 "vendor-defined device" sounds like DIY?

You can try and blacklist it (and the others that you don't need) on the dialog "Hardware->Device Blacklist". Move everything into the list on the right with the "ignore" button that isn't a game controller that you want to use with AAO. That includes all mice and keyboards, and everything else that isn't a joystick, yoke or TQ (etc.). Restart the app after doing that.

That being said - this is exactly why there is a demo version. If it doesn't work correctly for you, please don't buy it.

Edited by Lorby_SI


Share this post

Link to post
Share on other sites

Hi, thanks for the quick response! Agreed that I shouldn't purchase if not compatible - it's just that I've read so much positive feedback about it that I'd really like to exhaust my troubleshooting options first. 

The "vendor-defined" device is not a DIY, but I was able to trim this down by removing all of the vendor-defined devices out of Device Manager - they don't correspond to anything I want, need, or know to have installed, and they're on the stock MS USB driver, so that no longer appears in the logs. 

What it now seems to hang on is the "ITE Devices", that may be motherboard related, and which I've tried to remove but come back on next hardware scan. These devices don't appear in the hardware blacklist, but they get enumerated anyway, it seems.

Well, it appears that something in my motherboard may be triggering this issue - I will take your advice and not proceed with purchase, however, I truly appreciate your help.

Share this post

Link to post
Share on other sites
Posted (edited)

Sounds werid though.

You could also try running AAO with the command line parameter "-blacklistall" once. That should disable all devices that the app can see before it starts the actual scan.  


Edited by Lorby_SI


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...