Sign in to follow this  
Guest Maul

Thanks DX10! You Made FSX smooth!!

Recommended Posts

Not sure if this has happened with anyone else, but I had somewhat of a miracle last night. It seemed like the Microsoft gods were smiling upon me for once. I wiped my hard drives and re-installed Windows Vista, deciding to finally make the switch for good since I purchased my nvidia 8800GT (fantastic card). This isn't the first time I've installed Vista though, so I was sure I'd have a 6 minute call with a MS employee to validate my install of Vista, but when I went to activate Windows...successful! No call to MS this time! I thought that was pretty strange, but no complaints here. By this time, my fiance wanted to go to Wal*Mart, so I obliged and was about to buy one of those $25 rc helos (that seems to be a hot item this holiday season) but then I decided to stroll over to the electronics section. I said to myself, if they have a copy of Acceleration, I'll pick it up instead of the helo. To my surprise, I nabbed the last copy and put the rc helo back (I'll pick that up some other time.) When I got home, I installed FSX and was again, expecting to have to call to reactivate the software...again, no problems! What a nice surprise! After doing a short circuit at Friday Harbor with constant stutters at 20 fps with minimal everything, I wasn't very excited. Then, I installed Acceleration and kicked on the bloom, DX10, and aircraft shadows which usually had my machine stuttering from 20fps to 5fps to 20fps, etc, but this time it was smooth!! I thought I was hallucinating, I mean it was about 1:00am and I couldn't believe it! The only setting I have to pull back is the water, which I have no problem with because I don't like the high water setting. I decided to test my theory out in windowed mode, which when I did, brought my system to it's pre-Acceleration knees. Fullscreen is definitely the way to go now. I tested it out in Chicago, which has pretty heavy autogen, and it was going just great at 20fps with a stutter every now and then, but nothing like before. Even with bloom turned on, approaching O'Hare, I was holding 12-15fps that was amazingly flyable! It was great to see the car traffic while approaching 22R and full bloom, it was awesome! I just installed MyTraffic X, but haven't got the chance to play it (at work now) but I'm hoping that keeps the frames at an acceptable level. I'm sooooo excited that everything works now, flying that Blue Angel was awesome and I can't wait to do some carrier missions and SAR missions in the new military helo.After months and months of frustration, I'm finally making some headway and it's a welcome change. My upgrade to a 2.4GHZ quad-core and 8800GT 512MB has finally paid off. Even though I could run other games at super high settings, FSX was kind of my benchmark and now that it is running, I love it. Now I can finally stop tweaking, I can finally enjoy the sim. I hope others have a "eureka" moment like I did.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Congrats, I'm very interested. DX10 has potential to smooth most settings that FSX came with. For this, it's more than preview...What's your exact Water setting now? What settings do you need to reduce to get the same fps in DX9?Bigean

Share this post


Link to post
Share on other sites

I think my water setting is at 0 right now, but I'll check later this evening. Still might tweak a bit more, but nothing drastic. Honestly, running in DX9 mode doesn't work too well for me though. It seems that checking the DX10 preview was the best thing that ever happened to FSX for me. Flying that P51 around Minot, ND with a good amount of autogen, bloom and aircraft shadows checked was a blast!Eric

Share this post


Link to post
Share on other sites

Do you also see the shadows in 3D-cockpit?What's your Vista, 32 or 64?Bigean

Share this post


Link to post
Share on other sites

Yes, the key thing is full screen mode. I too get really smooth performance when in full screen with dx10. I posted about it a while back when acceleration first came out. Frame rates lower drastically when not in full screen!

Share this post


Link to post
Share on other sites

Bigean,I do see better lighting in the vc, but no cockpit shadows. Also, autgen looks like it causes those microstutters, any one found resizing the textures makes a difference or messing with the fsx.cfg?Eric

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this