Jump to content
Sign in to follow this  

FS2020 Start\Launching

Recommended Posts

I have used FS2020 Store Edition now for several years. To launch\start the sim I use the "gamelaunchhelper.exe" from the Content Folder. This has always worked OK for me.

Today when I tried to start\launch the game this method did not work to start FS2020. I have no idea why. It worked fine yesterday.

Any help\suggestions would be greatly appreciated.


Share this post

Link to post
Share on other sites

Open Microsoft Store and go into your Library. "Get Updates." See if that solves your problem.


13700KF | RTX 4090 @ 4K | 32GB DDR5 | 2 x 1TB SSDs | 1TB M.2 NVMe

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online

  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Create New...