Sign in to follow this  
stampee

shimmering trees help requested, I have read many other posts

Recommended Posts

Hello all: I have tried, searched these forums, and have read many other posts regarding shimmering trees, however I still have problems with them flickering. Normally I can run with FPS of 30-50 depending on the terrain. I am very happy with those frame rates and my VFR quality, except for the flickering trees. I have installed Nhancer and I can use that to prevent 99% of the flickering, however it causes a horrific FPS hit.If I set anti aliasing to Combined 16x3 I can stop 99% of the flickering, but my fps drops from 35 to 15/secondThis is hardly a benifit, because now I get choppy video with the low frame rates.I have tried every other setting I could think of using Nhancer to no avail. If I use Supersampling 4x4 I am not sure if I see any reduction in flickering. Maybe a tiny amount, but that is all. I am not sure if it is not a placebo effect it is so little. The only setting I can find that makes any difference is the 16x3 setting.I have Negative LOD bias clamped by the way. I tried the mipmap quality 6 in fsx.cfg to no avail. Maybe I entered the text string wrong? I saw no change whatsoever! I lowered autogen, but.. even 1 autogen tree flickers badly, so... For any suggestions, here are some things you should all know.I do NOT mind blurries! I know this is counter intuitive, but.. I would rather see blurries then flickering trees. The flickering hurts my eyes terribly and causes migraines. I have an LCD monitor set at 60 hz refresh rate. I read someplace that 60 HZ is optimal for LCD displays. I run at 1024 x 768x32bit resolution. The highest my LCD will support is 1366x768 and there is not that setting in FSX config. I do not have any more money to upgrade hardware. I already have gone broke now making this system. I can see only a few options for myself.1) Shut off all autogen: Even shut off I see some flickering, (I cannot recall why off hand though.)2) Use Nhancer on 16xs and suffer with horrificly low frame rates.3) change nothing, and put up with flickering trees and headaches (not really an option) any advice would be greatly appreciated. Once again, I have spent a lot of time searching for an answer to no avail.-Stampee

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

First of all to boost the overall AA to deal with the alpha textures such as trees is a waist of your recources so lets see if we can set you up correctly.Any mipmap settings higher than the default of 4 will reult in more and more flickering, to counter that you would have to turn AntiAliasing up so turn that back to the default of 4 or remove the line.These settings will help just AA the Alphatextures (trees, fences and such) and can be found in the Nvidia driver advanced menue:Not sure if the 7600 support this, I know the 78-7900s do but if you see "AlphaAA" or it might be called "transparency AA" set it to "suprsampling" and the look for "Gama AA" set it to on.now sett overall AA back down to 4s or 8s "overide application" and uncheck the AA box in FSX.Set your Aniso at 8 or better.Let us know how it goes.

Share this post


Link to post
Share on other sites

I turned downed my resolution the other day from 1680x1050 to 1440x900 and discovered the shimmering trees all of a sudden. Incredibly annoying. It was never there before. The only thing that had changed was the installation of Ground Environment X and FSGenesis terrain mesh. I haven't yet tried disabling them to see if one is the culprit or if there is a specific setting causing this. I'll mess around with later and see if I can find the cause. I don't believe its an AA issue or anything because it wasn't there a week ago when I turned down the res and now it is. When I turn it back up to 1680x1050 the shimmers are gone. I also installed the latest Nvidia beta drivers so that may be a cause as well.

Share this post


Link to post
Share on other sites

Digital: Thank you for the assistance. I am not positive I made the correct changes as you suggested. I THINK shimmering is better, to be honest I made so many changes and made things much much worse that I dont know where I am at now. I still have shimmering, I just am not sure if it is better, or after all the changes that it may be back to what I started with.Here is what I now have.In FSX I have trilinear filtering on, and AntiAliasing box unchecked.In Nvidia Control panel I have the following under Global settings.Anistropic Filtering 4xAnistropic Mip filter optimization OFFAnistropic Sample Optimization ONAntialiasing settings 8xSComformant texture clamp Use HardwareError reporting offextension limit OFFForce Mipmaps NONEGamma correct antialiasing ONHardware acceleration SINGLE DISPLAYNegative LOD bias CLAMPTexture filtering QualityThreaded optimization AUTOTransparency antialiasing SUPERSAMPLINGTrilinear optimization ONTriple Buffering OFFVertical Sync use 3d application Here is some more fuel for the fire. Watching very closely, I have just realized that autogen trees pop into view, whereas the background texture and buildings seem to be fine. I never notice them coming into being. The trees popping into view are very noticeable. I have level of detail distance in FSX set to Large. It is possible I changed something in my fsx.cfg file years ago if you know of any such setting. I made so many fsx.cfg changes because I was chasing low frame rates up until a month ago. I finally found out I had no AGP to cpu driver installed. DOH.Anyways, maybe these trees popping into view are causing part of this shimmering problem.Tree's on the horizon, or on the skyline shimmer much worse then trees right under me I also noticed just now.Thank you once again for your assistance.-Stampee

Share this post


Link to post
Share on other sites

Digital: I forgot to say. I also am NOT using Nhancer right now. I have it shut off. I presumed from your first post that I did not need it. All I could see Nhancer doing was if I used that 16Xs mode or whatever it was called, and then I would lose 50% of my FPS speed. It did get rid of the shimmering, but... SHEESH what a fps hog.-Stampee

Share this post


Link to post
Share on other sites

The plot thickens! I just learned something else. With engine off I see no shimmering of tree's or buildings. With engine on I see shimmering and also the buildings shimmer if I zoom in on them. The buildings sort of hop up and down a tiny amount. I dont think I could see buildings shimmer before because they are further away, and so much larger etc. It is like the effect/problem shimmering I now have is built in by Microsoft to simulate the shaking of the airframe. It is just more notable on the transparent tree's.I also see that if I shut off the engine while parked, and zoom in on an autogen tree, the tree shimmers a tiny amount while zooming, then the shimmer stops wherever I stop the zoom effect.This zoom shimmering also happens on the buildings. I dont care while I zoom of course, I am just trying to get to the bottom of this.SO,.... I think the autogen tree's shimmering that I now have may be built right into FSX to simulate engine movement. I am going up to altitude, shut off the engine and see what happens.All this is maddening. No wonder I am going bald!-Stampee

Share this post


Link to post
Share on other sites

OK, your on the right trail. Just a bit more work to do..>Here is what I now have.>In FSX I have trilinear filtering on, and AntiAliasing box>unchecked.Go a little further here and select Aniso instead of Tri, leave the AA box as is unchecked.>In Nvidia Control panel I have the following under Global>settings.First make sure you have texture or image "quality" set to max or "high quality" This will set Mipmaping at "0" (Hi-perf mode=more blury), You can adjust it down in the future to see if thats ok, but for now lets get you set up for a good visual.>Anistropic Filtering 4xYou are far better off increasing this to max esp if you are using 8sAA, you will take a small FPS hit, but not too bad for the great visual payoff. Aniso=16>Anistropic Mip filter optimization OFF>Anistropic Sample Optimization ONTurn S-Optimization off>Antialiasing settings 8xS>Comformant texture clamp Use Hardware>Error reporting off>extension limit OFF>Force Mipmaps NONE>Gamma correct antialiasing ON>Hardware acceleration SINGLE DISPLAY>Negative LOD bias CLAMP>Texture filtering QualityMake sure (as above) set Texture filtering to high quality.>Threaded optimization AUTO>Transparency antialiasing SUPERSAMPLING>Trilinear optimization ONTurn Tri-Opt Off (I think it turns off automaticly when you selct High quality mode anyway, but just check it off to be sure).>Triple Buffering OFFAfter you are setup, check your performance and get used to how it "feels" visualy, come back and turn T-buffering =on and see if you get a better sustained FPS>Vertical Sync use 3d applicationThe rest all looks good.Try and report back.BTW in FSX the AG does not nicely fade as it use to...it pops as you say. Yeah...moving forward...

Share this post


Link to post
Share on other sites

I'm particularly interested in this thread - I've never been able to get rid of the distant autogen trees shimmering in FSX; It's particularly noticeable in the northern hard winter with the trees against a white background. I'm using a 7950GX2 with Tweakforce 163.71 beta driver.

Share this post


Link to post
Share on other sites

Digital: I made all changes as suggested. I think the tree's are much better. I do not see as much or any of the trunks flashing like I did before, trunk flashing was very maddening. I notice that if I sit still on the runway, engine off, there is no shimmer. Engine on there is. Flying there is of course since the engine is running. I then did a high speed taxi and shut the engine off to coast. I see less shimmer while coasting. Is this some crazy design of Microsofts that they use a shimmer to fake the flyer into thinking they are seeing vibration caused by the engines? If so it is a horrific FPS hog as far as I am concerned.I am guessing at this because if you look really close at a building using zoom mode while idling on the runway you see the building hopping up and down. As I understand it, buildings do not use the transparent texture mode, so should not be shimmering.Do you, or other people see buildings hopping up and down while sitting on runway with engine running? You have to zoom in to a high level until the building is filling your screen before it is visible.NOTE: You have to move a tiny bit down the runway and stop. If you boot into a mission with engine running this effect is not apparent, until you move a tiny amount. I dont know why Nhancer on 16sX is getting rid of this effect except it is doing such a huge amount of anti aliasing that it is blurring all 4x4 grids and averaging out this built in microsoft shimmer.But... it takes 50% of my frame rate away, so...Popping trees added back in. That was very nice of them. I am sure every end user greatly appreciates the addition of this feature. Uggg...Thank you so very much. I think we are chasing ghosts now with this problem. I truly appreciate all of your efforts.-Stampee

Share this post


Link to post
Share on other sites

Well... to make a long story... longer... I have 99% of tree shimmering gone, at the expense of some blurries. I found out I can use Nhancer and set Negative load bias to allow, and then increase the LOD bias. Higher numbers reduce the shimmering at the expense of adding blurries. Ugg, I know it is a trade off, but at this time I do not have a better solution yet. I found an LOD bias of positive .500is a good tradeoff of sharpness of terrain and shimmering of tree's.If I got as high as 1.5 positive LOD I will get zero tree flickering, but have very obvious terrain and building blurries. I also see that to high an LOD bias causes the FSX in game menu bar to lose clarity, and become unreadable. I did not see any loss of FPS no matter what LOD setting I used. There may be one of course, but if so, it is very minor. To be specific my Nhancer settings are as follows.Enhancments tabAnti Aliasing combined 8Xs (16xs is great and takes out all shimmer, but causes a horrific FPS loss, to my taste this is not an option)Gamma correction ONSuper transparency AA ONAnistropic Filtering 16XOptimizations tabTexture filtering High QualityTrilinear optimization OFFAniso filter Optimization OFFAniso Sample Optimization OFFNegative LOD bias ALLOWAdjust LOD bias +.5 positive too +1.5 positive depending on your choice. NOTE: After making a change to the LOD bias, you MUST Activate the profile once again.For those curious... I know this is not a perfect solution and... why introduce the dreaded blurries? well... I can suspend belief and more easily pretend I am really flying if I see a slightly blurred ground, instead of going nuts from watching 2000 tree's flickering like mad in my face and looking like a bad string of flashing christmas lights on steroids.It is to bad all these tradeoffs for personal taste. Hopefully somebody has some more suggestions.-Stampee

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this