Guest Shep

No Tools in FSX menu bar

Recommended Posts

I'm having trouble getting the object_placement tool, Traffic Toolbox and Special Effects to appear in the FSX Tools menu bar. I delete the FSX.cfg and during rebuild, only get asked permissions for fsuipc although the three tools appear in the .cfg. I did try reinstalling the SDK to the same drive as FSX (E: after uninstalling SP2 first, then SP1a) but although the entries appear in the FSX.cfg I only got asked for permissions on the fsuipc entry. I do have 'user account' turned off and full permissions in Vista 64-BIT (updated to Vista SP1)fsx.cfg -[Trusted]E:Program Files (x86)Microsoft GamesMicrosoft Flight Simulator X SDKSDKMission Creation Kitobject_placement.dll.wetonkhnhelqlbqlhazoobowinelikalzabohlwz=0E:Program Files (x86)Microsoft GamesMicrosoft Flight Simulator X SDKSDKEnvironment KitTraffic Toolbox SDKtraffictoolbox.dll.rokauuktbrwercnoirihnatwhoiznenhannkubho=0E:Program Files (x86)Microsoft GamesMicrosoft Flight Simulator X SDKSDKEnvironment KitSpecial Effects SDKvisualfxtool.dll.znwaeecrclnwtkezcrewqakcnnzibiactqzlhwtn=0E:Program Files (x86)Microsoft GamesMicrosoft Flight Simulator XModulesFSUIPC4.dll.rokcqikuwczzqnwcuclrtbohllkiitklzqeituia=1I can change the =0 to =1 in the FSX.cfg but when FSX loads, the three tools revert to =0 again. Could anybody give me an idea what is causing this and perhaps how I correct it without a reinstall of FSX please.Ray

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Ray, You have to find the DLL.xml file (C:UsersYOUR NAMEAppDataRoamingMicrosoftFSX), open it with Notepad and replace the word TRUE with FALSE where you'll see the SDK entries DISABLED.Hope it helps

Share this post


Link to post
Share on other sites

Thanks for your interest David but no luck. The three tools did have the correct wording, as the copy of my complete dll.xml entry shows but still no tools menu in FSX. The tools will load into the FSX.cfg (after first deleting the FSX.cfg and allowing FSX to rebuild it) but all three still have the =0 not =1 and although everything else asks for permission when FSX is loading the three tools don't.<?xml version="1.0" encoding="Windows-1252"?>Launchdll.xmlFalseFalseAFXModuleFalseFalseE:Program Files (x86)AFXAFXModuleFSX.dllInstant SceneryTrueFalseE:Program Files (x86)Instant SceneryInstantSceneryFSX.dllObject Placement ToolFalseFalseE:Program Files (x86)Microsoft GamesMicrosoft Flight Simulator X SDKSDKMission Creation Kitobject_placement.dllTraffic ToolboxFalseFalseE:Program Files (x86)Microsoft GamesMicrosoft Flight Simulator X SDKSDKEnvironment KitTraffic Toolbox SDKtraffictoolbox.dllVisual Effects ToolFalseFalseE:Program Files (x86)Microsoft GamesMicrosoft Flight Simulator X SDKSDKEnvironment KitSpecial Effects SDKvisualfxtool.dllFSUIPC 4FalseModulesFSUIPC4.dllI did have the tool menu before I did a format/reinstall of my Vista HP O/S, reinstalled FSX, then the SDK off the FSX DVD, SP1, SDK SP1a, then SP2. I was asked to update my Vista HP to SP1 on the MS auto update and since all that, I have not seen the tool menu.Ray

Share this post


Link to post
Share on other sites

That could be the trouble David. I had forgotten to install the SDK Update for FSX Service Pack 2 so I'm downloading it now and will let you know how I get on after I install it.Ray

Share this post


Link to post
Share on other sites

That was it! I turned off the AVAST virus scanner, installed the SDK update for FSX Service Pack 2 and thanks to you, two or three days of frustration, trying to find the cause, have now ended.Sincere thanks David.Ray

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now