Archived

This topic is now archived and is closed to further replies.

bnic

These settings made a big difference

Recommended Posts

I have been experiencing random surges in FSX when setting my FPS slider to unlimited. I like to run it unlimited as I get better performance overall. In my attempt to remedy the problem I have come up with a combination of settings that have really helped with the problem. These probably wont work for everyone but worth a try. They are:1) I bumped my Texture Bandwidth Muliplier to 2002) Turned on MultiCore support in Nhancer (using the 174 beta driver)3) Added a MipBias of 6 to my FSX config4) Set the Pre Render limit to 1 from 3Change numbers 2 and 4 really made a difference for me.Thought I would pass on what helped my situation. If nothing else at least try #4 and see if you get a smoother sim.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

1. 200 is very high... if it works, great but 80-100 is pushing it close to over the top on current hardware2. Are you on Vista or XP? I have always found MC support best ON for vista and OFF for XP3. Typically that has an impact with photoscenery more than anything else but it can help on some systems.. it also reverts when you enter the settings and make any changes and on some systems it change when the sim is booted so verify it has remained and not changed. I have not seen a use for it since SP14. The default is 3 in Nhancer.. I do not know how that got set to 1 to begin with

Share this post


Link to post
Share on other sites

Actually I have the TBM at 100. I did try 200 but found it to be more jerky at 200. At 100 it seems best, I'll try 80 and see what happens. I also rechecked the MipBias and it stayed. I have no bluries whatsoever. I'm not understanding your remark about the Pre-render limit. It got set to 1 by me. Here is my thinking behind trying it. If FSX is CPU driven then why waste more CPU cycles by sending more frames ahead to the card. It seems that limiting it to one has really sharpened the ground textures (GEX of course). I also tried a setting of 0 and it freeked out FSX and crashed and I got a driver error of some kind. It also made the FSX screen all white showing no graphics. When set back at 1 all is well. Again the main thing that setting has greatly reduced was the surging I was seeing. While roaring down the runway it was as smoothe as my machine will allow but at take off when lifting off the ground I would see surges aor when flying in a more less dense area. Now I can leave my FPS unlocked and the surges have been greatly reduced.

Share this post


Link to post
Share on other sites

MipBias is one of those settings that may or may not help.. it was mostly used for shimmer reduction which 8xS Combined in the most recent version of Nhancer does quite well. It was reported to help with distance scenery on phototiles but otherwise I do not know of any benefits with it.. glad you dont have to deal with it resetting.As for prerender.. leave it at 3 because the VC is doing the work for you.. seting it lower is only forcing more on the system in real time where the CPU/card should be able to handle that in PR.I run a TBM of 80 specifically because of texture loads.. they come in sharp and remain that way at 80 on my system... any lower and I start seeing texture 'snap'. Any higher and I can start to see stutters which get worse as the value is increased so 80 is the sweet spot on my system.

Share this post


Link to post
Share on other sites

I tried going back to 3 on the Pre Render and the surges came back. I know certain settings only work on certain machines but the Pre Render of 1 makes a big enough difference for me to keep it. Nick this is off topic but I also have a issue with Fly Tampa St Maarteen Scenery where if I have Global Texture Res at Max I get huge FPS swings depending on the view. Actually if I view only the runway from outside looking straight down it drops to 4 FPS, yes I said 4. Almost everywhere else is normal. If I set GLOBAL TEXTURE to high then I can get normal FPS no matter where I look. I have posted this at FLY TAMPA's site but no solution or as to why. This happens no where else and the FSX default scenery is no problem. You being the GURU that you are, any idea as to why this happens?Thanks, Jim

Share this post


Link to post
Share on other sites

What hardware are you running? The PR should not be a problem however I have read that reducing it some see a differenceits like anything else with this title.. some cant run anything higher than the default TBM and others can.As for FT SM, I dont know because i do not use the scenery.. it sounds like something around the runway was not made right if others are seeing the same issue.Has anyone else posted the same problem?

Share this post


Link to post
Share on other sites

Hey Nick, er, Doctor. (from the other forum)Took the enhancer prescription after resisting for a while. What a great difference!! AA is so much better, and the color palette, without changing any color setting, looks much better too! Performance wise, I thought it was a slight to moderate increase, except for additional stuttering. Also, all areas I fly, FTX Blue and a few megasceneries, all is great except for the LA Basin area where my performance declines in the air. When approaching and landing at LAX, FPS goes back up to the low 20's at least, and taxiing there is smooth as silk. I'm going to try the settings here (pre render to 1, multicore for nHancer(XP))Also, you say the mip bias to 6 might help photoscenery so I'll try that later as well.Just wanted to give a big thanks for it's looking much better now. FTX Blue is just plain gorgeous. Better color, a little brighter, and the AA makes a huge difference, especially with the runways...perfect!

Share this post


Link to post
Share on other sites

additional stuttering can be from the 8xS setting.. it is a higher quality AA and its used to try and reduce shimmering to a minimum along with helping in the contrast area but the reverse of that is you may be seeing some limits on the system around large amounts of trees or other AG objects.You can try reducing to 4xS and see if that helps.. its a bit of give and take. I do not like shimmers of any kind so I work it from another angleWith large tree areas I compensate for it in bufferpools however I have a large VM card and can do that.

Share this post


Link to post
Share on other sites

I dont have a top of the line system for FSX but it gets the job done for now till I can finish a new system. I have a Pentium D 805 which from what I have read is (was) a great CPU to OC. It has a 20x multiplier with a low FSB. I was able to get it to 3.48 from 2.66 still on air. I have a 8600 GT 256 DDR3 Super Super Clocked version (SSC), 2 gigs RAM, Win XP tuned thanks to you and defrag using O&O. I get acceptable performance for me based on my hardware and have my sliders adjusted as so. Switching the Pre Render to 1 has given me one of the biggest improvements I have seen since I did the XP tune up. Thanks for all your great info and help on here and it is always a breath of fresh air to read your posts especially with all the dead horse beating threads I have been reading lately.

Share this post


Link to post
Share on other sites

I am interested to see what effect the Pre Render change has on your sim. It made a big difference for me.

Share this post


Link to post
Share on other sites

Good... Glad to hear it is working for you.. the slower system may like 1 better than 3. I did not realize you were running an older P procI will keep that in mind if i come across someone on an older rig and wish to try a few things:)

Share this post


Link to post
Share on other sites

Nick, after using 8xs, I think it might be hard to go back to a lower setting. The lines on everything are now perfect. The planes have a more defined, realistic look to them. They look different than before, so much so that I cannot believe how good they look. And the runways...on the ground (taxi lines are perfect), and in the air, even from a distance, the runways are gorgeous.Anyway, fiddeled around with a Honolulu update for Megascenery last night and was getting great performance. Up around Dillingham, FPS was bouncing around 80-100 fps...proceeded to lock the frames at 31 and the scenery presented was simply stunning. And yes, the 8xs setting does a much better job with shimmering water. Also shot a few landings around San Diego with great performance too. The only place that's somewhat problematic is the LA basin as I mentioned yesterday. I didn't make any changes to the settings last night, but JW is another person liking the 1 setting for pre render so that will definitely be tested out this week.You mentioned bufferpools which is something I've seen a lot about, from you and others. After I sort out the nHancer settings, I'll try adjusting that. I think you posted a setting of 100000000, though I could be wrong. My system is E6600 stock speed, 8800 gts 512, 2 gig RAM. Todd

Share this post


Link to post
Share on other sites

On 512 card you probably do not want to exceed 10000000 or 15000000 (10MB to 15MB)Its also a conditional edit... you may not have the condition present that edit will help. It's typically used when you see stutters in turns and panning.Post back how reducing the prerender works.. I am curious about that. I do not have slow systems and changing the value here has never displayed anything positive, although 0 is a no-no :-lol

Share this post


Link to post
Share on other sites

jwenham,We managed to reproduce your massive fps-drop when looking straight down. It has to do with the AA setting. If you use nHancer try Multisampling (4x or 8x) while keeping FSX's own AA checkbox Off. Supersampling & Combined appear to cause the single digit fps.martin / fytampa

Share this post


Link to post
Share on other sites