Archived

This topic is now archived and is closed to further replies.

irocx

FSX w/SP2, Vista 64 and Wow6432 question.

Recommended Posts

Hi again, I've made the migration to Vista64 and have noticed using ProcessMon that there are repeated and continual entries for FSX.exe trying to read the following registry entry: HKLMSOFTWAREWow6432NodeMicrosoftAPLUnfortunately it comes up repeatedly as "Not Found". Upon some research, I now understand that the OS uses this key to present a separate view of HKEY_LOCAL_MACHINESOFTWARE for 32-bit applications that run on 64-bit versions of Windows - an emulator. What I don't understand is how to prevent this "not found" from happening. I've read that even creating a "dummy key" to satisfy the call hasn't worked and I am sure this can't be the best thing for frame rates.Anyone with some ideas on solutions? Thanks.Regards, Kendall#1: E8500 @ 3.95 - HyperTX2 Gigabyte P35-DS3L 4GB Ballistix Tracers PC6400 EVGA 8800GT - XG's 174.74 Seagate 250GB 7200.11 CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 - X800XT Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Almost certainly not worth effort to resolve . . . even if it really is a problem. The FPS theory is almost certainly correct, but the measurement would most likely be in the .0000001s of a FPS. This loss of CPU cycles in this process is would be negligible. Fun stuff to explore, though. If you like this kind of detail, get process explorer and watch VS (the OOM stuff) and WS private (Physical ram) do the OOM dance. That's a 'fun fact' too.

Share this post


Link to post
Share on other sites

>Almost certainly not worth effort to resolve . . . even if it>really is a problem. The FPS theory is almost certainly>correct, but the measurement would most likely be in the>.0000001s of a FPS. This loss of CPU cycles in this process is>would be negligible. Thought this might likely be the answer - now I know. This is certainly not as bad as a file or texture repeatedly not being found. Sam, many thanks......again.Regards, Kendall#1: E8500 @ 3.95 - HyperTX2 Gigabyte P35-DS3L 4GB Ballistix Tracers PC6400 EVGA 8800GT - XG's 174.74 Seagate 250GB 7200.11 CH Yoke/Pedals/Saitek Throttle Dual Monitor: Dell 2405/1905 #2: Dell 8400 3.2 H.T. 3GB PC4200 - X800XT Diamond Xtreme/Logitech X-530's

Share this post


Link to post
Share on other sites