Sign in to follow this  
Guest

Gmax boolean problem

Recommended Posts

Help AVSIM continue to serve you!
Please donate today!

This is a common problem with boolean and shapemerge... if you change on vertex stage you will see extra/new vertices appeared to the edges of those windows. One solution is to collapse those extra vertices but if you have many windows, that may take some time..

Share this post


Link to post
Share on other sites

Or that is not the reason ;) Hmm it seems that you have drag those vertices somewhere by accident?

Share this post


Link to post
Share on other sites

I didn't! Trust me, just (boolean )cut and refine. I have redone it, and this is what happened again. Below is another pic of another try.Thanks,Tiberiu Brasov

Share this post


Link to post
Share on other sites

Hey Tiberiu.As Toni pointed out, boolean does not always work as you want it to.It is hard to see in the picture, but I believe the shading of some faces around the windows is the problem, right? Or are there faces going accross from one side of the window to the other? Hard to tell.Anyways, you might want to play with the cylinder you used to cut as Operand B, make it with more or less height segments and sides, and try cutting again.As Toni said, you might get away with collapsing and moving vertices on the edge of the window, but you do have to do it one by one. If it is too much of a pain, and if the fuselage cross section is contant, you can do a fuselage only long enough for one window, and then copy that entire fuselage part again and again until you get the fuselage length you want. Obviously a bad solution, but sometimes it is faster than adjusting vertices in all windows. But then again, I don't think the fuselage is very long, since I think this is a certain supersonic jet, besides the Concorde...Anyways, I would try the different cylinders first, and if that doesn't work, try adjusting vertices.P.S. Just saw the second pic. Yeah, way too many vertices, try and reduce the sides on the cylinder you use to cut.

Share this post


Link to post
Share on other sites

I think this is a certain supersonic jet, besides the Concorde...Much better...Citation XThanks,I will try the shape merge, maybe this will work.Thanks,Tiberiu Brasov

Share this post


Link to post
Share on other sites

It seems that you have used like 32 sided cylinder for the window? That ain't good for frames and it will probably make it look even worse if you try to cut it from low poly fuselage! you should decrease the sided to 6 or just few more and it should work quite well.

Share this post


Link to post
Share on other sites

No, no, no! You don't get it. I use boolean(cut-refine,) after that I detach the part from the fuse.Thanks,Tiberiu

Share this post


Link to post
Share on other sites

Go to the modifier stack and apply smoothing. That will fix it.Udo.:-wave

Share this post


Link to post
Share on other sites

Thanks, it looks alot better, but not like normal. What settings should I use? Thank you very much again! :)Thanks,Tiberiu Brasov

Share this post


Link to post
Share on other sites

I know how to fix it. You need to make vertical sections going through each window. then, before you do boolean convert the fuselage to editable poly. To make the Vertical sections the split tool.Paul Felz

Share this post


Link to post
Share on other sites

I did some experiments with two 18 sided cylinders, and found that boolean subtract A-B instead of cut-refine works much better in this case. With my projects I usually try both to see which works better. To fill the holes back in for the glass, apply a cap holes modifier or create the polygons by hand, using the polygon sub-object level and "create polygon". Hope this helps, Ryan the Glidiator

Share this post


Link to post
Share on other sites

So I have got to add more cros selections to the fuselage? Sorry, but I can't seem to get what you are saying.Thanks,Tiberiu Brasov

Share this post


Link to post
Share on other sites

Thanks, that is what I did to one of my first projects and it worked great, but I had another problem(see pic below)Thanks,Tiberiu

Share this post


Link to post
Share on other sites

Ok. I made a mistake. First convert your model to an Editable Poly.Then, select the Split (I think, gmax isnt working properly so I can't check) from the Point mode in the rollout. I think its slice plane, actually. It is a yellow line, and you drag it over perpendicular to the window, and hit Slice, or whatever the button is next to it. Do this for all the windows, and then hit Slice Plane to stop it. Now you can use Boolean to make the windows without all of the extra polygons. Sorry I can't give you a better description, but gmax has decided it doesn't want to work anymore.Paul Felz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this