Sign in to follow this  
crvm

Panel Graphics Question ...

Recommended Posts

Got a couple of questions regarding setting up a 2D panel. 1) Size of the "Default View". My project plane is in the startup scenario in Flight Sim. When first starting Flight Sim, the "Y" dimension is at mid screen approx., no matter what the panel config data is. If I reload the plane, (after loading a different one first) then it will size properly. See the two shots below. Current Data:X=0Y=0SIZE_X=8191SIZE_Y=4000How to fix this?2) Black tips on bitmap edges. When blaking out areas on the panel bitmap, there are black tips on the outer edge boundry between the panel and the outer view portion. Is there a way to fix this. I have tried trimming more of the area, but new tips occur. See last pic.Any helpful comments would be appreciated.Thanks!Bob C.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Yep the dreaded HALF SCREEN LOL! Make sure you set the IDENT to something other than 0 and see if that works for you. In the windows view order make the main panel second with an IDENT of 1.AS to the jaggies looking black, you have to go through each color along the edge and make sure there are no darker colours there. There must not be any blending along the edge with the 0,0,0, window.Best Wishes,Randy J. Smithcrvm@sbcglobal.net" A little learning is a dangerous thing"

Share this post


Link to post
Share on other sites

One more thing Bob, Always make a NEW flight after each cfg change that deals with {view} settings as FS2002 will ALWAYS load your previous saved settings. This can throw you off if you really had it set right the first time!Best Wishes,Randy J. Smithcrvm@sbcglobal.net" A little learning is a dangerous thing"

Share this post


Link to post
Share on other sites

Randy,Just a short follow up. Still haven't got the screen deal fixed yet, but did get a good portion of the "Black Tip" problem taken care of.The original panel bmp was 24 bit. I tried converting it to 8 bit/256 colors, and it seems to have worked. Still tinkering with it.Happy Holidays!!Bob C.

Share this post


Link to post
Share on other sites

OK, I'm frustrated now. By converting the panel bmp to 8 bit, the edges look better! BUT, now I find view changes very slow (3-5 seconds) when switching from front to side, etc. The original 24 bit switches with no lag. Just seems to be my luck.If anyone has a comment, I'm open for ideas.Thanks!!Bob C.

Share this post


Link to post
Share on other sites

Download the freeware CFG Edit from here at avsim.... It won't do the new xml gauges but it will help you set the proper panel views and you should still be able to use the 24 bit bitmaps. and itf you are going to make more panels or like to tweak existing ones, FS panel Studio is a very nice payware version of CFG Edit that at about $16.00 is well worth it and it will handle the new FS 2002 xml gauges.Brian

Share this post


Link to post
Share on other sites

Thanks Brian,I am currently using Cfg Edit, which has worked fairly well. I am checking out the FS Panel info. It's now $24.99, but may flip for it.Oh what fun it is, to ...Bob C.

Share this post


Link to post
Share on other sites

>OK, I'm frustrated now. By converting the panel bmp to 8 >bit, the edges look better! BUT, now I find view changes >very slow (3-5 seconds) when switching from front to side, >etc. The original 24 bit switches with no lag. Just seems to >be my luck. >If anyone has a comment, I'm open for ideas. >Thanks!! >Bob C. Hey Bob. Here is what you do for the "y" problem. Locate window entry with 0 ident that is the one that is visible on startup. Set value for THAT window to extend down enough to cover your new window. If you had panel studio it would be MUCH better to see what I am talking about. Is the aircraft the only panel in the cfg or is it added to another? Remember to NOT LOAD a previous flight to check, always start a NEW flight because FS remembers ALL settings from a saved flight and that could be one reason it sets correctly AFTER you re-load the aircraft.I use a 16 million bit bitmap {although fs uses 8/256}and there is always a slight delay to load the bitmap gauges, but after loading it will switch back and forth like normal.. Best Wishes,Randy J. Smithcrvm@sbcglobal.net" A little learning is a dangerous thing"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this