Sign in to follow this  
Guest electeddonkee

Why is Gmax exporting blurred textures?

Recommended Posts

Hello,I am having a very annoying problem with gmax. The model Im working on is done basically but when I export it and view it in FS, there is ALWAYS at least one texture that displays blurry on the model. Normally it is either both wing textures or one side of the fuselage. The textures are without MIP maps, yet still I am seeing blurred textures. As a side note, if I was to zoom in as far as I can and then zoom back out the textures are ok. But the next time the textures are re-loaded (ie when I change views) they are blurred again. I don't understand it! :(Also, in middleman, I noticed an option on export that was called "texture page hack". Anybody know what this does?Thanks for any help you can give me :)-Derek

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Make SURE that none of the affected textures have MIPS in them.GMax will NOT be the cause of "blurry textures," simply because the only thing exported is a FILENAME... :) That is, aside from opacity settings, specular level, and specular color...The "texture hack?" I have NO idea; I've never used it...

Share this post


Link to post
Share on other sites

Thanks for the reply, Bill. :) While the textures didn't have MIP maps in them, You are absolutely right about that gmax exports only the filename. I should have thought of that myself.As it turns out though, getting rid of all the colocated vertices fixed it. Also, I noticed that what also fixes it is adding an alpha channel to the texture. I was wondering why DXT BMP textures weren't having this problem, and it turns out it is because DXTBMP automatically adds an alpha channel when you save in DXT3 (It is a blank/white alpha channel, but an alpha channel none-the-less). Previously I was saving the DXT3 textures using imagetool, which wasn't adding an alpha channel at all to the textures. I don't know why the alpha has anything to do with it, but whatever lol.Anyways so the fix was adding alpha or getting rid of the colocated vertices. Why either of these things affect the texturing is beyond me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this