Sign in to follow this  
spokes2112

Help! Really strange autopilot problem

Recommended Posts

Hello,I'm having a really strange problem related to the aoutpilot. It happens with every aircraft and panel I have, so it must be something in the sim itself, not a specific aircraft or panel file. Whenever the main 2D panel is not visible on the screen, the autopilot loses pitch control. It happens in VC mode, outside views, looking to the side in the 2D cockpit, and even turning off the main panel window. Returning to the main panel view, the autopilot immediatly regains pitch control. I'm at a loss to even begin the look for the answer, but my knowledge in this area is pretty slim. Anyone have any thoughts?Thanks, Mel

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I think I just answered my own question. After reading through some other (unrelated) threads, I came across some information regarding autopilots and trimming. It appears ther problem was having the elevator trim mapped to a rotary dial (I'm using a Saitek X45) rather than to buttons. After remapping the trim to a pair of buttons, the problem appears to ahve gone away. Apparently, when the trim is controlled by a joystick axis, the autopilot can't take control of it properly. Why the problem only showed up when changing views is beyond me.Mel

Share this post


Link to post
Share on other sites

Mel, Happy you figured out at least the core of the problem. The 1st post was almost "THAT CANT HAPPEN" ...... Best of luck.. MayB head over to the hardware or the general forum. I'm sure 1 outta 65 gazillion :-) have the same setup. Regards,Roman(KGRB)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this