Sign in to follow this  

Recommended Posts

- - (G:VAR1,bool) - - - (G:VAR1) ! (>G:VAR1) 0 (>K:TOGGLE_VACUUM_FAILURE)I would like to have the Vacuum OFF at FS opening and have the possibility to switch it ON by a dedicated switch.This gauge works but in the opposite manner:When FS opens the vacuum works and by the switch it's possible to switch it off.How I can manage to have the Vacuum OFF at FS opening?Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

you say the switch works, but rather then switch it off at the simulation start, you want the simulation to start in the off mode?qualify the start and switch it off with the gauge.(G:Var1) 0 == if{ your code to switch it off 1(>G:Var1)} or change the G:Var for an L:SimStart,enum you could also make a config.ini to easy ... i am missing your question ?

Share this post


Link to post
Share on other sites

hi,You,ve got exactly the question:I want the simulation to start in the OFF mode but I'm not able to find a working code.Any help will be welcome.

Share this post


Link to post
Share on other sites

Try using this statement immediately after the Gauge name thus:-(L:Vacstart,bool) ! if{ (&(>K:TOGGLE_VACUUM_FAILURE) 1 (>L:Vacstart,bool) }- --This should toggle a failure as soon as the gauge is loaded.Also, Do you need the zero in this line?(G:VAR1) ! (>G:VAR1) 0 (>K:TOGGLE_VACUUM_FAILURE) Regards Ted

Share this post


Link to post
Share on other sites

Hi,(L:Vacstart,bool) ! if{ (&(>K:TOGGLE_VACUUM_FAILURE) 1 (>L:Vacstart,bool) }(G:VAR1,bool)(G:VAR1) ! (>G:VAR1) 0 (>K:TOGGLE_VACUUM_FAILURE)this is the gauge after your kind suggestion but the statement doesn't toggle the Vacuum failure as soon as the simulation starts.With or without statement the gauge still work in the same manner.thanks anyway for your replyRegards

Share this post


Link to post
Share on other sites

(G:VAR1) 0 == if{ (>K:TOGGLE_VACUUM_FAILURE) 0 (>G:VAR1) }(G:VAR1,bool)(G:VAR1) ! (>G:VAR1) 0 (>K:TOGGLE_VACUUM_FAILURE) hi to all,now the gauge works properly by the above code:At FS starting I have the Vacuum lack and the ADI are U/S.By the dedicated switch I can restablish the vacuum and get the ADI working.Thanks to all who gave me a very precious help.

Share this post


Link to post
Share on other sites

Sorry it was my fault - the (& should not have been in the line.Try this clean one. This is tested and works on my Wellington.(L:Vacstart,bool) ! if{ (>K:TOGGLE_VACUUM_FAILURE) 1 (>L:Vacstart,bool) }(G:VAR1,bool)(G:VAR1) ! (>G:VAR1) (>K:TOGGLE_VACUUM_FAILURE) The (G:Var1) will always initialise at zero and so does not need setting.Regards Ted

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this