Sign in to follow this  
Guest fsspn

FSX GaugeText in VC gauges always dark at night

Recommended Posts

Hello folks, i'm new here and i have a strange problem.I constructed the Grob SPn G180 for FS) (you can find in the file library) and i want to build a new version with VC in FSX.i read bill leamings tutorial for emmissive textures for illuminating gauges at night - most successfully. So i managed to make an illuminated MFD-screen. But when i wanted to put some text on it (with XML-code) this text stayed dark at night, even though i put the right commands ( ) to it, for example: ... 350.000,144.000TrueCOURIERred16%( (A:GENERAL ENG FUEL PRESSURE:1, psi) )%!09d! ...does anyone have a good idea? i'm confused!Thanks for your help!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

:-hmmm no one there to help me?or is my english too bad to be understood?

Share this post


Link to post
Share on other sites

I see no problem with your XML script. I'm assuming that the string does display, but remains "unlighted."Does it display "Bright" if the gauge is placed on the 2d panel?What is the background color of the MFD screen?

Share this post


Link to post
Share on other sites

:-) thanks for replying! i startet with 3D-panel, so there isn't yet a 2D-panel.the gauge text is visible, but dark.my big worry is, that my translation of your article (into german) is rather wrong, so i did not do the right thing.in gmax i made a flat rectangle polygon and attached on it a material with diffuse map and self illumination map.other settings:allow bloom=yes; source blend=one, dest.blend= zero, emissive mode= additive; no base material specular checked; virtual cockpit channel checked.In my translation i suggested, that there are several ways to get the emissive property and i chose the one with only one polygon. Did I understand something wrong?I'm confused... (sh... why did I not attend to my engish teacher years ago..)The colour on the self illumination map at the text position is black

Share this post


Link to post
Share on other sites

hooray!I got it! I readed the tutorial one more time...Then I returned the textures to "multiply blend" and transparent....nothing worked...The fault was: all my textures were in the ...texture folder.I put MyBitmap_C.bmp in the gauge folder... it worked! :-xxrotflmao thank you all the way for thinking with me!!!

Share this post


Link to post
Share on other sites

Wunderbar!Andi, all of your XML script and bitmaps should be in a sub-folder in the panel folder:..panel.....MyXMLGauge........MyBitmap_C.bmp........MyOtherBitmaps...........MyXMLGaugeScript.xml

Share this post


Link to post
Share on other sites

oh yes, i will do so!thanks a lot, perhaps i will give it back with a new FSX aircraft one time ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this