Sign in to follow this  
Guest

WaterLand Assitant?

Recommended Posts

Hi, I tried the landclass assistant of John Cillis, and it a very great tool, but, do you can do a tool (likes landclass assistant) that modify the water color on fs2002? I'm very novice in this area..., ThanksPablo

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hola Pablo,You can use Land Class Assistant to change the water class.Do not use the land class values. Use the water class values in the SDK documents.Then, change the inf file to:Type=WaterClassU8and compile as usual.Best regards.Luis

Share this post


Link to post
Share on other sites

Hi Luis!I tried to change the water with your metod but, I can't, the water don't change...This is the landclass.inf:[Destination]NorthLat=30.9375SouthLat=28.125EastLong=-15WestLong=-18.75DestDir = .DestBaseFileName = WATERclass[source]Type=WaterClassU8SourceDir=.SourceFile=landclass.rawLat=30.9375Lon=-18.75NumOfCellsPerLine=256NumOfLines=256CellXdimensionDeg=0.0146484CellYdimensionDeg=0.0109863In the landclass.raw i change to value 3, because I want a deep color sea, but nothing happens, the airport is GCLA.Pablo

Share this post


Link to post
Share on other sites

Hola Pablo,lo siento, I should have warned you.Land Class Assistant was made before we knew exactly how the process of creating land class worked (this was only found out a few months ago!)Land Class Assistant assumes that the grid is an array of 256 x 256. This is not true - the grid is 257 x 257.The result is that anything you place in Land Class Assistant will be displaced by one unit in both horizontal and vertical directions, and will not show up where you placed it, but approximately 1 km. away.The reason for the error is because the Microsoft Resample program takes the 256 x 256 raw image created by Land Class Assistant and resizes it to 257 x 257. This causes the displacement of the values.You must take this displacement into account when placing your land class (or water class) values, and just shift them by one unit in both directions.I assume that this is the reason that you did not get results, as everything else seems to be fine. Your inf file as created by Land Class Assistant has no problem.The only other possibility is that you have not placed the water class value on the right spot on the grid. Perhaps you could indicate the coordinates on the grid where you want to change the water.I also notice that there is a lot of bare desert (land class 8) along the coast. I have never been to the Canarias, but surely that is not right. Are you also changing the land class? It seems to need it.Best regards.Luis

Share this post


Link to post
Share on other sites

I found I had to use textures 55 thru 60 to get it to work. Also they may be misplaced so test a few off the coast a bit first.Andy

Share this post


Link to post
Share on other sites

Hello Andy,These are very interesting results. Perhaps you could elaborate?I have used other water class values with success. The only value that does not work is 12. This is because all the series 12 textures were not made.The only reason that I have found that you may not have success is because of the displacement of the values by Land Class Assistant.But, other than that, Land Class Assistant does a great job without any errors.Best regards.Luis

Share this post


Link to post
Share on other sites

Hi Luis.The only reason #12 doesn't work is because MS forgot to include the texture with the sim! You could make a texture ( DXT1 opaque mipped ), and name it "012b2wa1.bmp", place it in "...scenebd/texture', and it will show fine.A search of that folder, finding all filenames that contain 'wa', will reveal the water textures ( that may be viewed with imagetool ).It's a mistake to believe the textures don't show, as their function isn't only color, but depth as well. There's many similar looking water textures. The FS2002 terrain_sdk's "Terrain Texture Names.doc" gives not only valuable landclass texture information, but waterclass info as well. For waterclass, each number corresponds to a texturename:043 is 043b2wa1.bmpDepth does have an effect with floatplanes. 'Shallow Inland' types aren't really the best for floatplanes. Nor is 'Shallow Ocean Water 1'.The worldwc.bgl can be viewed with TMFViewer, to see all the types of the default water in the world.As with landclass BGLs... they should reside in a project's 'scenery' sub-folder, and there should be no twin 'texture' sub-folder.Dick

Share this post


Link to post
Share on other sites

"The result is that anything you place in Land Class Assistant will be displaced by one unit in both horizontal and vertical directions, and will not show up where you placed it, but approximately 1 km. away."I want to correct one issue. The most recent version of LCA includes factors to compensate for this displacement. While not 100 pct, in most cases landclass will be placed within the limits of MS's landclass "resolution", but that means that some landclass assignments will still be offset, since there's a limit to how accurate one can be.... Since I designed LCA to calc the x,y vertice placement based on lat/lon, if the lat/lon falls between vertices, LCA has to make the best guess as to where to locate the point. There is no way, even using a 257x257 .raw file format, to get around this, as there is no way to exactly place a lat/lon to a point.Also, the .inf posted in the thread is not the correct one to be used with LCA. The factors LCA uses to place points (based on lat/lon) are based on the .inf file posted to Avsim's library, and included with my 1.3 update. The last two lines should be:CellXdimensionDeg=0.0147058CellYdimensionDeg=0.0110293I understand the issue cited with the 257x257 format. But the latest version used with the correct .inf file will place landclass with the maximum precision allowed by FS.

Share this post


Link to post
Share on other sites

Hi Luis,I checked the MS waterclass file worldwc.bgl ? with tmfviewer and found the values from around Hawaii or somewhere. I will have another look at the ones Dick mentions, which I was aware of following the sdk/Christian Stocks'tutorial, but couldn't get them to work at that time. I had discovered that landclass assistant would process waterclass in isolation and had posted how to in the forum on oceania.net, subsequently discovering this thread. Will have to have another play around.Andy

Share this post


Link to post
Share on other sites

Thanks Dick,I discovered I had overlooked the Terrain Texture Naming doc and textures 55 thru 60 were the only ones of those that I tried by chance that worked, I have the old resampler. It seems depth has a lot to do with it. All's well now. Andy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this