Sign in to follow this  
Guest Larrycx

Bias option in the FS9 Scenery SDK

Recommended Posts

I'm going crazy trying to make this simple piece of code work. The following doesn't compile with the 'BiasXYZ' section in but it's fine without it.Does anyone know what the correct syntax is? Thanks in advance.<?xml version="1.0"?>(BTW don't bother what it is - it's pretty meaningless really but based on my real code. But it should still compile.)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

"BiasXYZThis element is used to add an X, Y, Z bias in meters to the placement of an object. The acceptable range for of values is unbounded, but it is recommended that biases only be applied for small distances. If this element is used inside of a SceneryObject it must come before any instances of AttachedObject, Effect, GenericBuilding, LibraryObject, Trigger, Windsock. This element is not allowed to contain other data and must be terminated with

Share this post


Link to post
Share on other sites

Hi W and thanks as usualTalking about moving things, if Mr Gates would like to bend over I know where I'd like to move this whole Scenery SDK thing x( I cannot believe that the people at MS can have been so sloppy in its presentation and I think that with the profit they make out of flight simmers we deserve a whole lot better than what we've been given.I've managed to work my way through all the SDK coding bugs that I've needed to so far but this one STILL eludes me. I've tried moving the 'BiasXYZ' code and whatever but it will just NOT work. I can't believe that something so apparently trivial can bring (as in my case) a project grinding to a halt. Shame on you MS and a thousand curses on you and your houses (as they say :( )Any more ideas anyone?Roger

Share this post


Link to post
Share on other sites

Hi, The reason I am replying is that I want to subscribe to this thread in case someone makes bias work. I too want to move a building a small distance. I too have the compile error problem. I too cuss the SDK often and a lot.Larry Costa

Share this post


Link to post
Share on other sites

Gentlemen,I'm pleased to say that the syntax as originally shown with the 'BiasXYZ' inside the AttachedObject now compiles correctly with the updated SDK published today.Thanks for small mercies......:-jumpy Roger

Share this post


Link to post
Share on other sites

Sigh......Given up on trying to make BiasXYZ work though. Change the numbers and nothing happens. Can't stand any more pain so now I'm just placing beacons as objects.So....Why don't the library object beacons rotate like the default ones do in the sim?Or do we have to beg and plead with MS to release yet more data.This is all just too bloody for words. Does it HAVE to be like this for chrisake??????x(Roger

Share this post


Link to post
Share on other sites

<?xml version="1.0"?>=====================This works with the new BGLComp ( version 2 ) from MS' SDKs.Dick

Share this post


Link to post
Share on other sites

Whee, Whoopy, etc.Now can unsubscribe to this thread. Got the new SDK stuff and will see what new bugs we can find! I may even keep trying to learn Gmax now that I can export my efforts.Larry Costa :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this