Sign in to follow this  
Guest Larrycx

So where are the FS9 library objects?

Recommended Posts

Hello all, I want to use the Gmax attach tool. It wants me to navaigate to the library in FS9. Where is it? My FS9 is at: F:Flight Simulator 9 .Larry Costa

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You only need to navigate to a folder if you are attaching an effect -- in which case it is just the Effects folder you want.For attaching objects, just press Esc at the browse prompt.

Share this post


Link to post
Share on other sites

Thanks for the reply. I still want to know where the library objects live in the FS folders, they must exist someplace. I tried in Gmax to attach a sailboat from the stock library objects. I built a small box, converted to editaable mesh then went to tools-run script, navigate to my FS folder & hit esc. picked the attach object radio button & filled in the name and GUID from Library Objects.xls with copy-paste. No object appeared in Gmax just my box but the SDK says its like that. I exported it, plugged in the coordinates in the xml and compiled eith BGLcomp. Put the BGL into FSsceneryaddon scenery and found the box but no sailboat in FS.What am I doing wrong? could the box I built be enclosing the the entire sailboat? I thought the box was just a dummy object.Larry Costa

Share this post


Link to post
Share on other sites

>What am I doing wrong? could the box I built be enclosing the>the entire sailboat? I thought the box was just a dummy>object.You didn't use Helpers/Dummy to make the box, but created a normal box, right?That's why your box is being displayed in FS... :)

Share this post


Link to post
Share on other sites

There are generally two reasons why I get the placeholder showing up, rather than the library object:1. I forget to press the Attach Object! button;2. I've accidentally excluded library objects in the vicinity.

Share this post


Link to post
Share on other sites

Tried making a dummy object (only object in view) and attaching a stock library object via name and GUID. Seemed to attach OK in Gnax but on try export got msg..."Assertion Failedgmaxpluginsmakemdl.exeFile FS9sdktoolssourcemdlviewocttree.cppline 386Expression m_iLevelCnt > 0For info on hgow can cause assertion failure see visual C++ doc on asserts."I don't know anything re Visual C++ it says press retry to debug JIT must be enabled. I don't know from nothinge re: JIT.I'm about to give up on attaching a stock object and exporting in gmax. If I don't use a dummy I get the box thaty is supposed to be the attached object per the changed object name in Gmax.Larry

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this