Sign in to follow this  
Guest jmfabio

How to unlight roads.

Recommended Posts

Greetings, I am posting this question again. I am using Ground2K4 to do a WW2 airbase in UK, and really like the program. But how do I get my roads that are on the airbase (roads other than dirt) to be unlit? I place them and make sure that the ckeckbox for night lighting is UNCHECKED, but in FS9, they are lit. Am I trying to do the impossible? Regards,Joe

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hello Joe,This is not impossible - in fact, if you do not place a check mark in the option, then you should not be generating those bgls.Check the bgls in your scenery folder. Perhaps you generated night-lit roads before and have not removed them yet.They should be the ones that end in "09" or something. Just remove them to stop them from displaying those roads.Best regards.Luis

Share this post


Link to post
Share on other sites

Luis,Thanks for your interest. I have double and tripled checked. I can assure you that the option is unchecked. I have deleted any bgl_09 in the scenery folder, I have even generated bgl from an new "clean" file of that area, and I still come up with night lighting. I have tried different types of roads, concrete ,asphalt, undivided, divided, one lane, ten lane, even bridges are lit. But that option box remains unchecked. I even tried all versions and patches: v.5, v.5.30,v5.32,v5.33, same result: can't put the lights out! I don't know what else to try. I am obviously missing something. Any suggestions would be welcome and appreciated.Best regards,Joe

Share this post


Link to post
Share on other sites

Hello Joe,The night-lit roads are not made using the terrain functions (VTP2) - rather, they are the old-style SCASM roads.Check inside your Ground2K4 folder for any scasm (.sca) files. They are the ones that are used to generate the bgls that display these roads.If you do not select the night lighting option in Ground2K4, then these scasm files are not created and the relevant bgls are not made. So, you should not be seeing night-lit roads at all.Unless, of course, you had previously created such roads, placed them in a scenery folder, and forgotten to remove them. Or, if there is a bgl by someone else in your scenery library that is displaying such roads.Perhaps you could show us a screenshot of your roads at night? This would be interesting to see.Best regards.Luis

Share this post


Link to post
Share on other sites

Hello again Luis, and thanks for your continued interest and help. The were no scasm files in my scenery folder. There was an afcad file, two files from FSSC (macros and flatten) and 3 from Ground2K4 the xxx_5.bgl and the xxx_9.bgl, and a landclass file.I keep my addon sceneries external to FS. I have no other sceneries for that area of the UK. But to be sure I completely removed the folder and Made a new project file in Ground2K4. That new project has only one item a test road, and thus only generated one file: the xxx_9.bgl. So consequently my new scenery folder has only that one file in it. Here are the screen shots.The area during day with no bgl.http://forums.avsim.net/user_files/83187.jpgThe area at night with no bgl.http://forums.avsim.net/user_files/83188.jpgView from inside Ground2k4 for the road I am placing.http://forums.avsim.net/user_files/83189.jpgThe area with the raod.http://forums.avsim.net/user_files/83190.jpgThe area with road at night.http://forums.avsim.net/user_files/83191.jpgIt bothers me when computers have a mind of their own and do inexplicable things.Best regards, Joe

Share this post


Link to post
Share on other sites

Hi Joe.If you look at the FS9 terrain.cfg, under the listing for texture 1138, you'll note tsis:Textures=hiwaysu.bmp,hiwayhw.bmp,hiwaysu.bmp,hiwaysu.bmp,hiwaysu.bmp,hiwaylm.bmpThe bolded text is the night texture. That's what you see.The only ways to avoid this is to learn to use "named" textures for lines with G2K4 ( eliminates the autogen ). Or alter the terrain.cfg and get rid of the night texture entry. Or alter the night texture to show black. ( Unless there is a default road number that doesn't use a night texture ).Dick

Share this post


Link to post
Share on other sites

Hello Joe,Sorry, my mistake. When you mentioned that you had roads lit at night, I assumed that you meant the old-style scasm roads. If you have ever seen that type of road, you would understand why they are so objectionable.What you have is not that, but rather the default FS9 roads. I have not flown at night in quite a while (I know, I know, I am not night-current, so shall have to do my 3 touch-and-gos some evening), but do not remember seeing that kind of road. I thought that they were all dark (??). Weren't there some replacement textures that gave this night-lit effect for roads?Anyway, if these are the default textures and not replacement textures, then, as Dick said, you have a number of possible solutions. You could just find that highway texture and make it all black - you would then no longer get night-lit roads anywhere in the world. There are also the other solutions that Dick mentions - they are all a little more complicated, though.One other solution is not to use roads at all. Draw them as polygons, and declare them as VTP2. Then assign a texture of your choice.As you see, there is a lot to explore. Don't hesitate to ask if you have any problems.Best regards.Luis

Share this post


Link to post
Share on other sites

Hi!I don't know how to work this out in Ground2k but if You handedit the ASM file, You will find at the end a list of textures used in the ASM file. Somewhere You will find VTPTextureName "1149" or something like this. You can change this line then to something like thisVTPTextureName "hiwaysu.bmp;hiwaysu.bmp;hiwaysu.bmp;hiwaysu.bmp;hiwaysu.bmp"I don't know exact sequence from my mind but order of textures is important; one is for winter, one for summer, one for... and the last one if I remember exactly is night texture.This way You won't need to change TerrainTextures.cfg, You can do it directly in Your file.Just to mention, this way it is possible to use all autogen textures but autogen won't appear on polygons/roads.Best regards,Goran BrumenFS Slovenija 2002 teamhttp://slovenia.avsim.net

Share this post


Link to post
Share on other sites

Hi Dick,Thanks for that useful info about the terrain.cfg. I explored it and as near as I can tell there is no default road texture that is unlit at night. I guess by using "named" textures you mean textures that I make and name myself? If so I am not quite sure how to utilise them in Ground2k4. Must I make an entry in the terrain.cfg so it shows as an option in the LINE/SHORE box in Ground2k4? And if that is the case must everyone make the same change in the terrain.cfg if I decide to distribute the scenery? Thanks again,Joe

Share this post


Link to post
Share on other sites

Luis, Thank you for your time, interest and help. I have tried drawing them as polygons but after numerous attempts was not satisfied with the results. As for Dick's suggestions, editing the terrain.cfg to get rid of the xxx_lm.bmp and changing the xxx_lm.bmp to black don't seem satisfactory solutions as I would lose most, if not all, night lit roads. The "named" texture option seems like something I would like to try, but I am not sure that I know what he means. Is it that I create a texture of my own? And if so how do I access that in the LINES/SHORE option in Ground2K4?Best Regards, Joe

Share this post


Link to post
Share on other sites

Hi Joe.Ground2K4 has a file in it's "Resource" folder named "OwnLines4.txt"This file can be altered to add texture sets for lines://---------------MyTextureSet--------------[Texture.8000] // concrete / 2 lanes / divided medianType=2Size=4Textures=hiwayhw.bmp;hiwayhw.bmp;hiwaysu.bmp;hiwaysu.bmp;hiwaysu.bmp;Leave a blank line nefore and after this entry, and place this at the end of the file. This is the same set as 1138, but note the semicolons as separators.There are spaces for 6 textures:winter;hardwinter;spring;summer;fall;nightI left the night absent, but it should still compile... with out any night texture. ( I'm hoping this doesn't cause a memory leak :( )Then fire up G2K4, and your new set should be a new line option... no pictures for it.I'm attaching the text file...save the default ownlines4.txt as ownlines4.old to save it for future use.Dick

Share this post


Link to post
Share on other sites

Hi Dick,Thanks for the info. I will have to experiment a little. Because I am running into problems. I locked everything up and FS9 refused to load. Had to go to a restore point. I think what caused it was the fact that I didn't put the textures in my scenery folder, and FS9 was trying to find them in the main texture folder. After having placed them in the texture folder of my new airport's folder,my dirt roads and a section of the default road next to my airport were blackened at night, with no lights.Despite the problems it is good for this old dog to be learning new tricks.Best Regards,Joe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this