Sign in to follow this  
Gridley

Slarti and watermasks...

Recommended Posts

I've generated a watermask using terrascene 2.1 of an entire globe tile (fly) that weighs in at about 800mb as a tga. I've managed to convert that to raw using irfanview, then to a bmp in photoshop CS, but slarti fails to load it with the following:--> Loading water dataScaling ".KLEB SourceKLEB-centerw.bmp" Promoting image type 1 to 16-bit***Failed to promote image to 16-bit. Check that it has noalpha channel. e.g. in Photoshop, select 'Layer->Flatten Image'.This will be fixed soon!*** Failed to load image.The watermask only has a single value - ignoring it completely!*** Problem preparing watermap - erasing it.*** Failed to load source file(s).The bmp is 'flat' in PS, maybe there's an advance format of bmp that would work, or am I beating a dead horse here? I've tried several of the obvious choices for bmps to no avail. Thanks!sg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi,You could try to save the raster image in TIFF format.I use TIFF format and that works OK both for 8-bit and 16- bit images. The only difference is that with 16 bit you do not have to wait for slarti to "promote to 16-bit. :-cool

Share this post


Link to post
Share on other sites

Thanks for the tip - I'll give that a try. I tried various 16-bit bmps, and raw directly, but neither worked. tiff is a new one!I'll let you know how it turns out...sg

Share this post


Link to post
Share on other sites

Nope. Tried 8- and 16- bit tiffs, no joy. Same error with the 8 bit, the 16 bit says the image contains only one value and is discarded. I have a feeling that something else is going on here. I must be missing a step somewhere. I've gotten the mesh part to work fine from 1-arc second srtm data, and the tga from TS2 looks fabulous as a watermask, I've just can't get slarti to use it...Any other suggestions?? Slarti is looking for the north west corner for the start point for the watermask, right?Thanks...

Share this post


Link to post
Share on other sites

Hi,in Photo Shop make sure all water is 100% black and all land is like 53% grey. You do this with the adjust Brightness/Contrast in the Image Adjust menu. Make sure you have the info window open to see these values. You open the info window in the window menu. :+If you have an image with black water and white land, then simply reduce the brightness untill it shows 53% grey for land. You may have to do it twice because total white only gets to like 39% grey when you reduse brightness to -100. Black will remain 100% black! :-cool If this does not work, try reinstalling the program and read the manual again. :)

Share this post


Link to post
Share on other sites

>If this does not work, try reinstalling the program >and read the manual again. :)Thanks for the tip - I think my land value is more like 40% grey, I'll check that out...and read the manual again. This is cutting into my shrike time!Best,sg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this