Sign in to follow this  
Guest Lucky

Ground2K4 texture visibilaty problem

Recommended Posts

Hi.I am new working with G2k4.Ive read the manual and the update for G2K4 several times and cant figure out my problem.When I draw out a poly and insign a texture # say #93.I compile and put the bgl into the scenery.My layout comes out with sections sharply cut off.I have even changed the layer value several times.I cannot figure out where Im going wrong. Ive been at this for 2 days now , re reading the manuals over and over looking for something Im missing.Please help me.See attachmentThanks Lucky

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Lucky,I'm not entirely sure what you expect to see. Any VTP2 or LWM polygon will have a sharp boundary defined by the shape and extent of the polygon you drew in Ground2K4. If you're looking for smoother blending you'd need to switch to landclass placement, though that is limited in its spatial accuracy to about 1.2 by 1.2 km (a LOD13 Area).Or, did you mean to say that part of the polygon you drew is missing?Cheers, Holger

Share this post


Link to post
Share on other sites

Thanks for replying HolgerI am very formilliar with programs like EZ LC .I am totally new at this program but want desperatly to learn to use it.I dont want the blend like you get in that program.What I am trying to achieve is a definite outline for my textures.If you notice the attachment you will se the top right section of the farm land is cut off.It is supose to be 90* yet it looks like it blends into the default LC and than there is a sharp 45* section where it is completely cut off.In other attemps where I drew in the boundries for a small town, the texture #117 i used blead well over the boundries I drew in .I will try to sen an attachment with exactly what I mean.Thanks Al

Share this post


Link to post
Share on other sites

Hi Al,Do I understand the image correct if I say that the redlines are the shapes you want to show (and how you drew them)?In that case it seems to me that you have trouble with concave polygons not displaying correct. I don't know how Ground2k does this internally, but it could be that the shape is too complex (and needs splitting).Have you tried to split the polygons into two different polygons and see if that helps?

Share this post


Link to post
Share on other sites

Hi Al,Got it now! Arno is on the right track there - it's a problem with the shape of the polygon. The easiest way to get around this is to open the Ground2K4.ini file in a text editor and define "VTPConcave=0" (you can do the same with LWM polys, as in "LWMConcave=0"). When you look at the difference of the output in LWMViewer you'll see that setting those parameters to "0" instead of "1" creates polygons with many triangular slivers. It would seem that they have a bigger impact on frame rates than the cleaner code created with "1" but I've never noticed any difference in my projects.The alternative is to draw only polygons with very simple shapes but that's not always possible or feasible.Cheers, Holger

Share this post


Link to post
Share on other sites

Thanks so much Arno and Holger.I really appreciat it.I will try your sugestions and reply back on my sucess. My brain is a bit messed from a really bad head on colision with a large truck so I have a real hard time trying to explain myself.I than you for taking the time to pic through my wording to understand what Im trying to get across.ThanksLucky

Share this post


Link to post
Share on other sites

Holger.Thank you.I figured out my problem.I added thos lines to the bottom of the G2k.ini file. Than about 4am this morning it hit me.I was not creating an exclude file excluding the layer # that I associated with the layer # I am using for my texture layer.Redid that and all is well.Also I chose to break up my tarm texture into smaller polys.Thus not so many angles and curves.The idea worked well.Than you and Arno so much for your help. Now back to work here.Lucky

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this