Jump to content

Sign in to follow this  
Bill Womack

VTP2 polys and water masking??

Recommended Posts

Hi gents,I've got a little glitch that I'm attempting to work around, and I thought I'd harness the collective mind to help solve it...I'm attempting to lay down a small (2 LOD13 areas) VTP2 poly with a "253" texture and a couple of custom terrain tiles. I've got the process working pretty well with one exception. I've created an alpha channel in my image to mask out the water (this scenery is on a coast) and even though the textures are saved as DXT1 w/alpha, I'm getting a shadow over the water where the mask is. I've attached a pic for clarity. Is is not possible to overlay a VTP2 poly and have it completely masked for the water?thanks,

Share this post


Link to post
Share on other sites

Hi Bill.VPT2 doesn't mask water... that's for LWM. An 8-bit, mipped, with alpha, will be transparent in the alpha-mask. I'm not sure what a DXT1 with alpha is doing.Dick

Share this post


Link to post
Share on other sites

Genius, Dick! That was indeed the problem. Using 8-bit textures w/alpha fixed it right up. Apparently that's the only way to go for this particular kind of masking.thanks a bunch,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...