Sign in to follow this  
Guest CapnCol

Gmax and LOD's

Recommended Posts

Can someone out there give me a little help please? I have created my terminal buildings in Gmax (ver 1.2 and using FS2004 SDK's, MDK's etc from Microsoft) and have tried to apply LOD's to my buildings. I have followed the tutorial to the letter and everything appears to work as it should. I have the "dummy", the LOD_100, 050 and 010 as expected. However, the number of faces (polys or whatever) have increased due to the addition of these other LOD's and this has resulted in a bgl that is at least twice the size of the original.This causes me major problems in the sim as the scenery just blurs completely and the frame rates go down to virtually zero (well 3 or 4 anyway).If I remove the bgl with the LOD's and just use the original, everything is okay, frame rates are about 9 - 10 and no blurries. Anyone have any idea what I have done wrong?Colin

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Colin,I've not had those problems with LODs before, but I'll try and help you sort them out. First off, I haven't measured them but it stands to reason that the overall size of the BGL would be larger with multiple LODs, as more geometry information is stored in it for each of the levels. Are you linking your LODs to the dummy object? And have you checked them by viewing the list of parts by name with the "display subtree" box ticked? If the grouping is right, you should see the dummy at the top of the list, followed by indented list of LODs. I've attached an image for demonstration.http://forums.avsim.net/user_files/118415.gifIf the LODs are named properly and are linked to the dummy, you should only see one LOD at a time onscreen. thanks,

Share this post


Link to post
Share on other sites

Thanks Bill, I can see right away where I've gone wrong. The tutorial I use only indicates linking the original model to the dummy, not the others, seems I've got a bit more work to do yet then.One more thing though, what do the numbers used in the LOD represent? and is there any preferred value for buildings?Thanks again.Colin

Share this post


Link to post
Share on other sites

Thanks Bill and Arno for the links, I have now redone all my scenery and linked each LOD to the dummy (which I did not do before). I also found that by doing it wrong in the first place, my scenery object doubled in size and because there was no link to the dummy, there was too much load on the sim - hence the blurred textures.There's so much to learn, yet so little time, but thanks to you for helping me out here I appreciate it.Colin

Share this post


Link to post
Share on other sites

Sorry Dick, I meant to say thanks to you for the links and for the help contained in the links. :) Colin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this