Sign in to follow this  
rhumbaflappy

Photo Scenery Maker Alpha Problem: Help!!

Recommended Posts

Hi There!!Recently I Decided to ewnter the scenery elite, and started my project of a Photoreal scenery , my home region, the Portofino Area...The scenery is 406 tiles, and is almost diagonal-cutted by the coastline...After lots of tests i turned to photo scenery maker that lets me include seasonal textures and night maps...after i found all the batch applications needed around in other scenery programs, as finding fs2000 SDK resulted impossible...I started the thing...Everything goes fine, textures and BGL are generted, BUT:Full sea-covered areas have their alpha ignored and appear as ugly white squares on the scenery... it looks like a conversion problem as bitmaps that are not fully transparent just work fine...I tried lots of things like using FS texture converter instead of PSM's internal converter, etc... after lots of hanging around re-compling scenery , bitmap names output misteriously changed and now the scenery does not work!!! The latter may be a problem of FS scenery caching...?Can you tell me what's going on???Heeelllppp!!!!Mario NoriegaProud http://www.euroavia.net/common/images/logo_euroavia.gif "Euroavia Pisa: European Association of Aerospace Students" International Editor Member

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

What you need to do is make sure that your installation has current components.This includes the TMF files and the Imagetool.exe program from the SDK. The FS2000 SDK won't work, so you need to download and install the 2004 SDK. After installating, set up Photo Scenery Maker with the correct install paths, close out and restart.If that doesn't work, then the other option is to completely uninstall everything and reinstall fresh installs of the FS2004 SDK and the current or latest version of the PhotoSceneryMaker application.Also, you need to make sure that your areas depicting water need to be a separate bitmap, and that there must be no color gradients. Water is black, and the rest is white. You also need to make sure that your master bitmaps are in the 24-bit color format.

Share this post


Link to post
Share on other sites

Hi!!Actually solved the problem...first: i was playng around with coordenates and there was an error...so the scenery jumped somewhere else...!! solved this, i too found the origin of the water bug... water needs to be black 0;0;0 not only in the alpha channel if a tile is fully water....Fs2000SDK was found in a link in terrabuilder's site...!! jumped there the right executables and discovered i had the right ones...FS200220044 SDKs won't work at all as TMF2BGL.EXE and TMFCOMPRESS.EXE are no longer present...it's hard to find the FS2000 SDK these days...THnks for the help!!Mario NoriegaProud http://www.euroavia.net/common/images/logo_euroavia.gif "Euroavia Pisa: European Association of Aerospace Students" International Editor Member

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this