Sign in to follow this  
Guest stitch23

FS Architect - Photo Texture Grid not working in FS2K4

Recommended Posts

I've recently started a project in FS Architect trying to recreate my home airport in Port Lincoln, Sth Australia in Flight Simulator 2004. I have layed down the runway and the apron and tried using the Photo Texture Grid to lay down some satellite images that I got from Google Earth.I converted the images into 16 256x256 pixel DXT-1 bitmaps using the Image Tool that comes with the FS2K4 SDK. But no matter how hard I try this textures will NOT show up in Flight Sim!I've tried all the image formats that the SDK offers with no luck, also tried copying the textures to all the texture folders in the FlightSim folder.I have included some screenshots of FS Architect and in game to illustrate what I have done, any help with this would be greatly appreciated as it is starting to become VERY frustrating!FS Architecthttp://forums.avsim.net/user_files/156811.jpgFS2K4 In-Game (Where the textures are supposed to appear)http://forums.avsim.net/user_files/156810.jpg

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Do you have a folder in Addon Scenery calledPort Lincoln or similar ??In that folder should be folders calledScenery and should hold the.bgl for Port LincolnTexture and should hold the textures for the 16 lods256x256 pixel DXT-1 bitmaps should be O.K.You also have to add the scenery in SCENERY LIBRARYSome free tools you might needCell Grid cellgrid2004a.zipTCalc2004OnTop by richard ludowisePhoto Scenery Maker by Takuya Murakami

Share this post


Link to post
Share on other sites

Yes, my first guess would also be that the scenery might not be loaded correctly. Normally when a texture can not be found, you still see the untextured polygon, but that is not the case here. So are you sure your BGL files are actually loaded?

Share this post


Link to post
Share on other sites

Thanks for your response Tasmanet and Arno. I have the folders arranged like this:C:Program FilesMicrosoft GamesFS2004Addon SceneryPort LincolnScenery (Containing the .bgl files)ANDC:Program FilesMicrosoft GamesFS2004Addon SceneryPort LincolnTextures (Containing my .bmp files in DXT-1 format)I have also added the Port Lincoln folder to my Scenery Library, without luck.Anymore suggestions?Just off-topic, check out www.simboard.net and help me get my forum started =DThanks again- Ben

Share this post


Link to post
Share on other sites

Well next step would be give some thought to the fact that you can have 5 seasons .If your textures are not saved to summer xxxxxxx_SU.bmp you might not see anything.It cant be the alpha set to all transperant (black), as youwould only see water.If you want a night texture "LM" I usully run them through PSPand decrease the brightness -100 and contrast -40.Save each texture changing the xxxxxxx_SU.bmp to xxxxxxx_LM.bmpTassie Devil.Down but not out.

Share this post


Link to post
Share on other sites

>C:Program FilesMicrosoft GamesFS2004Addon SceneryPort>LincolnTextures (Containing my .bmp files in DXT-1 format)I hope this is a typo? The folder should be called Texture and not Textures, else FS can not find your textures.

Share this post


Link to post
Share on other sites

>>C:Program FilesMicrosoft GamesFS2004Addon SceneryPort>>LincolnTextures (Containing my .bmp files in DXT-1 format)>>I hope this is a typo? The folder should be called Texture and>not Textures, else FS can not find your textures.I read your reply and I hoped that you were right! That would've been a very simple solution but I checked - the folder is called 'texture'.=(

Share this post


Link to post
Share on other sites

OK, that would have been to simple :).So the BGL and texture files are in the correct folder, but you don't see anything. Looking at your screenshot you do see the taxiway you made in FsArchitect as well, so the BGL file seems to be loaded correctly.It is most likely something with the textures I would say. Did you also add mipmaps to them, when you converted them to DXT1 format?

Share this post


Link to post
Share on other sites

I wont stake my life on this but I still thinkthe file name is incorrect as per my post above.You are trying to replace existing ground texturesand not using a groundpoly ??The grid looks a bit small to meThe image file is fine and has mipmaps

Share this post


Link to post
Share on other sites

If you are replacing the ground texture itshould be something similar to the attachment.ie 4 textures would cover all of the airport.You can use up to 512 x 512 DXT1If you are using a ground poly/plane you could getaway with one and use a 1024 x 1024 DXT3.For better quality use 4 planes with 1024 x 1024 texture.Tassie Tiger

Share this post


Link to post
Share on other sites

I finally got it working everyone! I think it's because I forgot to set the season characteristics inside of FS Architect. LOL! Thanks for the sizing advice Tasmanet I shall do that =DCome and check out my new FlightSim forum guys! It hasn't got enough members yet!!!www.simboard.net

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this