Sign in to follow this  
Guest

AFCAD causing FS2002 to crash

Recommended Posts

Hello,I have not been able to figure this out. I am trying to use this awesome new program by Lee, AFCAD. But to no avail. I have tried installing downloaded airports that people have modified and also just making maybe one change like moving the tower, to airports on my own but I cannot get it to work. What happens is I open the airport, save the airport, Start FS2002 and it goes to buliding new scenery, then the next step updating scenery database. Then on the last step indexing scenery files, FS2002 crashes and defaults back to the desktop, once it gets about 27% done. I posted this same message over at flightsim.com and I got a couple of responses. I restored the AFD files from the FS2002 cd and that did not help. I removed all my add on aircraft thinking maybe that would help. Nope no go! I did a search on this forum and a couple of others, and there are a few people out there that seem to have the same problem I do, but no solutions as of yet. Any help here would be appreciated as I would love to take advantage of this superb add-on by Lee.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

All I can say at this point is email Lee and see if he can help...-- Tom GibsonCalifornia Classic Propliners: http://members.aol.com/tgfltsim/index.htmlAlcoHauler Locomotive Page: http://members.aol.com/alcohauler/home/alcohaul.htmlFreeflight Design Shop: http://www.freeflightdesign.com/ San Diego Model RR Museum: http://www.sdmodelrailroadm.com/Drop by! ___x_x_(")_x_x___

Share this post


Link to post
Share on other sites

I have same problem with AFCAD, when FS start building indexes for new facility files at 35%, it display an error message:FS2002 caused an error on FACILITIES.DLL, FS2002 will close.I have been doing changes but nothing happens.I wrote to Lee, and stiill waiting for reply.If anyone knows something about, I would be grateful.Thanks in advance.

Share this post


Link to post
Share on other sites

I tried my best to explain this problem to Lee prior to his releasing AFCAD. The problem is the way he is handling the GUID (what I have termed as the 'hash code') with his software. Until he rewrites that portion of the code, this problem will tend to crop up again and again with more and more people being infected by it.The only way not to experience the problem is to not use AFCAD until he gets it fixed IMHO.-john

Share this post


Link to post
Share on other sites

Lee has contacted me back one time with some advice but they did not work, and I have contacted him back with the results and am currently waiting for his response. If it will help anyone this was his advice so far:Hi, Did you by any chance use an add-on 'gate enlarging' tool on FS2002 at some time? There is a gate enlarger out there that corrupts your facility files and may result in them becoming unusable if you later modify or add an airport with AFCAD. You can restore all the original facility files from the FS2002 CD, disk 1. They are in file called FS2002.CAB which you can open with WinZip, or another zip program. You will want to extract all the .bgl files from that CAB file to the following FS2002 folder, replacing the files that are in there now :

Share this post


Link to post
Share on other sites

One more thing I tried thinking maybe just maybe...I removed all my other add-on type scenery thinking maybe there was some kind of confliction...but it did not work....I will be patient for Lee to solve this one I guess.

Share this post


Link to post
Share on other sites

Thanks plumley1, I will try your advises. I am still waiting reply from Lee. Before apply this advice I put FS2K2 on business again, restoring original .bgl file from the backup made for AFCAD in:

Share this post


Link to post
Share on other sites

Same problem here. Just wanted to know if you found out anything further. Thanks.

Share this post


Link to post
Share on other sites

Nothing yet still waiting patiently for Lee to get back to me.

Share this post


Link to post
Share on other sites

Well I tryed this. And IT WORKS NOW! I inadvertently opened up the .cab and started to extract "all" the files in the .cab into my scenedbafdfilesscenery folder, as soon as I realised what I did I stopped it. Luckily it only put a couple of filefolders that I was able to delete(fortunately I had it set to use folder names also), then I just extracted all the .bgl files from the .cab(using no folder names)and the new afcad airport files loaded up fine. I also did the "microsoft libraries fix"(win98)that was on another message board but that was not the problem as my error was fe.dll not the one that was mentioned and I was still getting the error.

Share this post


Link to post
Share on other sites

Just an update folks on where this problem stands. It is unsolved. I have did a complete uninstall of fs2k2. I removed all related files and did a clean install of fs2k2, and the same problem occurs. (see above 1st posting in this thread) I have given up, Just for the sake of arguement I downloaded add a gate and tried it and the same thing happens. It crashes on the building indices part of the startup of fs2002. This is not a flame on the two authors that made these awesome programs! Obviously it is a internal problem probably with windows. So maybe a complete default setup on my machine would work but I am not ready to do that. So I am posting one last time to get any input I can. Tom and Lee have been helping out great. But is there no one else with a good idea / lead? Any input would be appreciated.

Share this post


Link to post
Share on other sites

If add a gate is crashing on the building index stage then there is ONLY one reason. There must be a NON default bgl file which is corrupt in the scenedb/afdfiles/scenery folder (or a default one that is corrupt). eMail me a copy of scenery.dat file located in scenedb/afdfiles folder. john@stottlemire.net-john

Share this post


Link to post
Share on other sites

Try this:1. Move all files in the AFDFiles folder to a folder outside FS (i.e. C:temp).2. Extract the AFD files from the CD, putting them into the AFDFiles folder.3. Restart FS.Now try it.If this doesn't work, you may have a corrupt AFD file on the CD. Try extracting using someone else's CD.Hope this helps,-- Tom GibsonCalifornia Classic Propliners: http://members.aol.com/tgfltsim/index.htmlAlcoHauler Locomotive Page: http://members.aol.com/alcohauler/home/alcohaul.htmlFreeflight Design Shop: http://www.freeflightdesign.com/ San Diego Model RR Museum: http://www.sdmodelrailroadm.com/Drop by! ___x_x_(")_x_x___

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this