Sign in to follow this  
wsieffert

Can't get AITM to work

Recommended Posts

I used the AITM installer, verified that all OCX files are in the proper places, and I used TDecompiler (Control+D) to make the TXT files.I then start AITM, then file open flight plan. I see the progress as the txt files are read into memory. After that point, nothing functions as the documentation states.I can't get any of the buttons to respond. The only function that works is Add Project File. It shows the Aircraft and Flight Plan files, but the Timetable, Shuffle, Move, and Export tabs are blank and unusable.I'm using the latest SP1 version.Any ideas on what is wrong?Thanks,Bruce

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Open the text file with notepad and see if anything is in it. My guess is somehow you are not decompiling the BGL file.Try decompiling manually using traffic tools.Matt

Share this post


Link to post
Share on other sites

Already tried both ideas before posting.When I used TTools, I can see the 19,000+ lines decompiling. With I open all 3 of the TXT files, they are complete.This is why I'm stumped as to what is wrong.Bruce

Share this post


Link to post
Share on other sites

When you say you are use SP1, do you mean AITM SP1 or WinXP SP1. I am using WinXP Pro SP1 and have been using AITM since it was originally offered and have had no problems with any of the updates including AITM1.2 SP1.If you are using WinXP, you can run fs2002 without it being registered in the Windows registry. However, programs, such as, AITM, TTools, AFCAD, need the registry information to work. If you are having problems with any other tools then you need to reinstall fs2002 to register it in the Windows registry. This can also be a problem in earlier Windows versions. See below for easy way to reinstall without loosing your present version.When you load the FlightPlan.txt file, AITM looks at your FS2002 folder for installed aircraft information. It sounds like AITM cannot find your fs2002 installation.If you are not using WinXP, I would recommend you visit www.flightsim.com , Must Have Files, download and install the Visual Basic 5 and 6 files again.Reinstalling fs2002 to add to Windows registry:Make a copy of your present fs2002 folder and rename it fs2002OLD. Uninstall fs2002 using the Windows Add/Remove Programs in Control Panel. Use Windows Explorer and delete the residual fs2002 folder (NOT the fs2002OLD folder). Reinstall fs2002 to the same drive as before. Once reinstalled, start fs2002 to ensure it operates correctly, exit fs2002.Copy the fs2002 folder and rename it fs2002NEW. Rename fs2002OLD to fs2002. Start fs2002 and ensure it works properly. If it works properly you can delete fs2002NEW.

Share this post


Link to post
Share on other sites

Answers to some of the questions:I'm running AITM1.2 SP1 on WinME. I read the FAQ section at the AITM website and saw that the registry needs to point to the FS2002 path. So I used RegEdit to add the recommended EXE Path key. That should have solved the problem, but it appears that it didn't, so that is why I originally ended up asking for help with this post.The only thing I have not done is install the VB 5 and 6 files again. I already have them on my system, but it wouldn't hurt to install a second time. However, I'm doubtful this is going to fix the problem. I think the root of the problem is that AITM can't find the FS2002 path in the registry, even with the new key that was added.Rather than go through a complete install of FS2002, could someone post their registry keys here so I can compare mine and see if anything is missing?It would be under HKEY_LOCAL_MACHINESOFTWAREMicrosoftMicrosoft GamesFlight Simulator8.0Thanks,Bruce

Share this post


Link to post
Share on other sites

OK, I solved my problem.For the benefit of others that read this searching for a solution, the problem was that AITM could not find the EXE Path key in the registry.I read about this solution in the FAQ section of the help docs, but I mistakenly created a new key instead of created a new string variable in the 8.0 Key section of the registry.So if you have the same problem I reported, look into your registry with RegEdit and navigate to the following key:HKEY_LOCAL_MACHINESOFTWAREMicrosoftMicrosoft GamesFlight Simulator8.0Inside this key, you will see at least a null value Default variable. Perhaps you will have other variables as well, I don't know what they should be since no one responded to my key request in this message thread.Left click your mouse in the variable area of the screen and choose, New, then String Variable. Give it the name "EXE Path". Then left click on the EXE Path variable and choose Modify. In the dialog box that appears, enter the full path to FS 2002. Then exit RegEdit.You will need to reboot your computer for the registry changes to take effect. As soon as I opened a flight plan.txt file, the program behaved as described in the docs.I want to thank those people that responded to my posting. I appreciate the help you offered.Bruce

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this