Sign in to follow this  
Guest

CH Pro Pedal cut out - HELP REQUIRED

Recommended Posts

Since purchasing my new computer (spec. below) I have been experiencing problems with my rudder pedals.Invariably, when powering up the Flight Sim, I have to disconnect and reconnect the USB lead to the pedals to get them to function. I then can fly for a period, differing in length, when they once again cut out, necessitating the reconnection routine.I have downloaded the latest 4 in 1 drivers for the Asus m/b and noting a previous posting, have unticked the boxes in the Device Manager/USB Root HUB "Allow the computer to turn off this device to save power" all to no avail.Whilst not a serious malfunction, it does spoil what is otherwise a very enjoyable virtual flying experience.Thanks for any ideas on the above.My Spec

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have the same problem occassionally except that I have never had them cut out after initially reseting them.Out of habit I always go to an exterior view to make sure everything is operating correctly before starting my flight (part of my pre-flight inspection :-)). If not, I simply unplug the device, wait for the XP disconnect signal and then plug them back in. Then they work fine.Have no idea what is causing this. I do not use the CH drivers because I have found no need to with XP.

Share this post


Link to post
Share on other sites

Its a known problem with XP. When i was running XP i would get exactly the symptoms you were discovering. The only advice i could find was with regards to a "suspend when idle" feature found through the device manager. I checked the box to disable the feature hoping it would resolve the issue but nope, still had it.. So i was left in the same position again, having to unplug and then plug back in to regain the operation of the pedals. I tried on various USB ports that i have my system (default on the board, addon 2 port pci card, 2x 4port hubs) but still had the problem... Annoying yes, but as of yet i have not heard of a way to fix it. Anyone else able to shed light on it?http://www.avsim.com/vfr_center/avsim_sig.jpg

Share this post


Link to post
Share on other sites

I also have the same problem-I downloaded latest usb drivers from via and ch.I am not sure the blame totally is on ch's shoulders-I have a usb printer and every once in a while my computer won't even boot up unless I unplug it. Seems like there are still many problems with usb devices. I do wish there was a fix for the rudder pedals.:-madhttp://members.telocity.com/~geof43/geofanim2.gif

Share this post


Link to post
Share on other sites

I've found that if I run FS2002 after my computer has been in standby mode (Win XP Home) then I have problems with the pedals in FS. I've noticed that after 3 or 4 disconnect/reconnect cycles while in the simulator the problem eventually clears itself. If I run FS after a reboot I don't have any problems with the pedals. It seems to me like the pedals don't like standby mode for some reason.Tony

Share this post


Link to post
Share on other sites

Hi Biggles,I'll also chime in on this one as this might help. I have WinMe, and I have 4 usb ports. Two in the front, and two in the back. I have 10 USB Devices for my WinMe system. I run the Hub in the back with the Keyboard, Mouse, Printer and Hub , and I have My CH Yoke and Pedals plugged in the front.I had problems If I installed the Ch Yoke and pedals either in the ports in the bak or through the hub.My Hub is a powered hub, so Make sure, if you can, don't run the Yoke or pedals on the hub or the usb port closest to where the hub is running, and try and run the Pedals and Yoke on your first two ports.I find that you have to experiment with what devices you have running. Since my current setup, I have not had any problems ever with the yoke or pedals. I also unplug the Yoke and plug in the Joystick using the same port if I want to fly those whirlythingamajigs.I have also seen people having problems if they installed the CH Control Manager software, so if you have that running, get rid of it, do what I posted above and then you should be golden.Hope this helps,Regards,Joe :-wavehttp://home.attbi.com/~jranos/mysig.jpg http://avsim.com/hangar/air/bfu/logo70.gif

Share this post


Link to post
Share on other sites

Hi JoeThank you and others for your responses. At least I am not alone with my problem - it's annoying but not fatal.Yes I too have tried various positions in which to attach the pedal USB connection, avoiding the powered hub and favouring the first position on the computer, but again with no luck.I'll keep scouring the Avsim forum, someone may come up with a solution.Thanks anyway.

Share this post


Link to post
Share on other sites

This may be the same solution that Aidin mentioned above, but you may want to try it anyways. It has worked for other XP users:Your default settings in XP allow the computer to put the USB hubs "to sleep" if they are not used. To resolve this, do the following:1. Open up the control panel from the start menu.2. Open "System" properties (found under performance and maintanance if you are using category view).3. Select the hardware tab.4. Open device manager.5. Expand the Universal Serial Bus controllers6. Right click on any USB Root Hub and select the power management tab.7. Deselect the option "allow the computer to turn off this device to save power".Hope this helps.

Share this post


Link to post
Share on other sites

Hi you all,I've been suffering with the same problems and tried all above mentioned solutions: no solution.Contacted my reseller and his answer:"so there's a problem with your pedals"He gave me a new set and YES!! Since a month I'm flying without any problem with the pedals, using the default WindowsXP install.So if you're sure you tried all solutions, give this one a try!!CheersJohan van WijngaardenEHAM

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this